summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbug2019-05-09 18:54:55 +0300
committerbug2019-05-09 18:54:55 +0300
commit8b32741224199e528b9d591f376cd90fa03d6d84 (patch)
tree1e05702e3795102980650f3ebe81e426a6f8a613
parent5fb9ba86c3ed22a16d81e934a2569e1de1282903 (diff)
downloadaur-8b32741224199e528b9d591f376cd90fa03d6d84.tar.gz
Update to 1.4.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2920b1d3e5b6..e2fcef6708bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
+# Generated by mksrcinfo v8
+# Thu May 9 15:54:00 UTC 2019
pkgbase = tsv-utils
pkgdesc = Command line tools for large, tabular data files. Filtering, statistics, sampling, joins and more.
- pkgver = 1.1.15
+ pkgver = 1.4.1
pkgrel = 1
url = https://github.com/eBay/tsv-utils-dlang
arch = i686
arch = x86_64
groups = dlang
- license = BSL-1.0
+ license = Boost
makedepends = git
makedepends = dub
makedepends = ldc
@@ -14,7 +16,7 @@ pkgbase = tsv-utils
makedepends = make
depends = clang
depends = liblphobos
- source = git+https://github.com/eBay/tsv-utils-dlang.git#tag=v1.1.15
+ source = git+https://github.com/eBay/tsv-utils-dlang.git#tag=v1.4.1
sha1sums = SKIP
pkgname = tsv-utils
diff --git a/PKGBUILD b/PKGBUILD
index d81f2974c618..81bd50571364 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
-# Maintainer: Sebastian Wilzbach <seb [at] wilzbach [dot] me>
+# Contributer: Sebastian Wilzbach <seb [at] wilzbach [dot] me>
+# Maintainer: Bug <bug2000@gmail.com>
pkgname=tsv-utils
_pkgname=tsv-utils-dlang
-pkgver=1.1.15
+pkgver=1.4.1
pkgrel=1
pkgdesc="Command line tools for large, tabular data files. Filtering, statistics, sampling, joins and more."
arch=('i686' 'x86_64')
groups=('dlang')
url="https://github.com/eBay/tsv-utils-dlang"
-license=('BSL-1.0')
+license=('Boost')
depends=('clang' 'liblphobos')
makedepends=('git' 'dub' 'ldc' 'liblphobos' 'make')
source=(
@@ -15,7 +16,7 @@ source=(
)
sha1sums=('SKIP')
-bin_files=(
+_bin_files=(
'csv2tsv' 'number-lines' 'tsv-filter' 'tsv-pretty' 'tsv-select' 'tsv-uniq'
'keep-header' 'tsv-append' 'tsv-join' 'tsv-sample' 'tsv-summarize'
)
@@ -30,11 +31,11 @@ package ()
{
cd $srcdir/$_pkgname
mkdir -p $pkgdir/usr/bin
- for file in "${bin_files[@]}"; do
+ for file in "${_bin_files[@]}"; do
install -m755 bin/$file $pkgdir/usr/bin/$file
done
mkdir -p $pkgdir/usr/share/licenses/$pkgname
mkdir -p $pkgdir/usr/share/bash-completion/completions
- install -m755 bash_completion/tsv-utils-dlang $pkgdir/usr/share/bash-completion/completions/tsv-utils
+ install -m755 bash_completion/tsv-utils $pkgdir/usr/share/bash-completion/completions/tsv-utils
install -m644 LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE.txt
}