summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBogdan Burlacu2019-08-07 13:30:40 +0200
committerBogdan Burlacu2019-08-07 13:30:40 +0200
commit06d86610f518259c194113541513f5ebff328251 (patch)
tree3d81fd52aaff3e0a859f8bf0d01210d2c26b2505
downloadaur-06d86610f518259c194113541513f5ebff328251.tar.gz
Add PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0040906187d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tsv-utils-bin
+ pkgdesc = Command line tools for large, tabular data files. Filtering, statistics, sampling, joins and more.
+ pkgver = 1.4.2
+ pkgrel = 1
+ url = https://github.com/eBay/tsv-utils
+ arch = x86_64
+ groups = dlang
+ license = Boost
+ provides = tsv-utils
+ conflicts = tsv-utils
+ source = https://github.com/eBay/tsv-utils/releases/download/v1.4.2/tsv-utils-v1.4.2_linux-x86_64_ldc2.tar.gz
+ sha256sums = a159a4f7e916b9ed25fcafe73468ec43f0bb6756746192bddacba0f1fd2ffbb4
+
+pkgname = tsv-utils-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a1fc18edb65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Bogdan Burlacu <bogdan.burlacu@pm.me>
+
+pkgname="tsv-utils-bin"
+_pkgname=tsv-utils
+pkgver=1.4.2
+pkgrel=1
+pkgdesc="Command line tools for large, tabular data files. Filtering, statistics, sampling, joins and more."
+arch=('x86_64')
+groups=('dlang')
+url="https://github.com/eBay/tsv-utils"
+license=('Boost')
+provides=('tsv-utils')
+conflicts=('tsv-utils')
+
+source=("${url}/releases/download/v${pkgver}/${_pkgname}-v${pkgver}_linux-x86_64_ldc2.tar.gz")
+sha256sums=('a159a4f7e916b9ed25fcafe73468ec43f0bb6756746192bddacba0f1fd2ffbb4')
+
+_bin_files=(
+ 'csv2tsv' 'keep-header' 'number-lines' 'tsv-append' 'tsv-filter' 'tsv-join' 'tsv-pretty' 'tsv-sample' 'tsv-select' 'tsv-summarize' 'tsv-uniq'
+)
+
+package() {
+ cd "${_pkgname}-v${pkgver}_linux-x86_64_ldc2"
+
+ mkdir -p $pkgdir/usr/bin
+ for file in "${_bin_files[@]}"; do
+ install -m755 bin/$file $pkgdir/usr/bin/$file
+ done
+
+ mkdir -p $pkgdir/usr/share/licenses/$pkgname
+ install -m644 "LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+
+ mkdir -p $pkgdir/usr/share/bash-completion/completions
+ install -m755 bash_completion/tsv-utils $pkgdir/usr/share/bash-completion/completions/tsv-utils
+}
+