summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Bisson2015-06-08 18:54:29 -0500
committerJonathan Bisson2015-06-08 18:54:29 -0500
commit74a08582f6ba7b4bb90ea35330de4e02e693a09f (patch)
tree893b6625c41d95f0be65295ccd7d559775a68f7d
downloadaur-74a08582f6ba7b4bb90ea35330de4e02e693a09f.tar.gz
Initial import
-rw-r--r--.AURINFO19
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD55
-rw-r--r--service13
-rw-r--r--tt-rss.install4
5 files changed, 112 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..0cd8243239a0
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,19 @@
+pkgbase = tt-rss-git
+ pkgdesc = Web-based news feed (RSS/Atom) aggregator (Git version)
+ pkgver = 1.3.0.r4196.g0c4c0ab
+ pkgrel = 1
+ url = http://tt-rss.org/redmine/
+ install = tt-rss.install
+ arch = any
+ license = GPL
+ depends = php
+ optdepends = mysql
+ optdepends = postgresql
+ optdepends = php-curl
+ conflicts = tt-rss
+ source = Tiny-Tiny-RSS::git://github.com/gothfox/Tiny-Tiny-RSS.git
+ source = service
+ options = !strip
+
+pkgname = tt-rss-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..912a7a378e59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = tt-rss-git
+ pkgdesc = Web-based news feed (RSS/Atom) aggregator (Git version)
+ pkgver = 1.3.0.r4196.g0c4c0ab
+ pkgrel = 1
+ url = http://tt-rss.org/redmine/
+ install = tt-rss.install
+ arch = any
+ license = GPL
+ depends = php
+ optdepends = mysql
+ optdepends = postgresql
+ optdepends = php-curl
+ conflicts = tt-rss
+ options = !strip
+ source = Tiny-Tiny-RSS::git://github.com/gothfox/Tiny-Tiny-RSS.git
+ source = service
+ sha256sums = SKIP
+ sha256sums = 8c33ab29cdb2eda25724e738ed04cb472a7fec0a9edca45729f29b17c46e55df
+
+pkgname = tt-rss-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..137b5a0fcc21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Bjonnh <bjonnh-arch@bjonnh.net>
+# Based on the tt-rss PKGBUILD
+# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+# Contributor: Clément Démoulins <clement@archivel.fr>
+# Contributor: David Rosenstrauch <darose@darose.net>
+# Contributor: Erik Mank <erik@braindisorder.org>
+
+pkgname=tt-rss-git
+_gitname=Tiny-Tiny-RSS
+pkgver=1.3.0.r4196.g0c4c0ab
+pkgrel=1
+pkgdesc='Web-based news feed (RSS/Atom) aggregator (Git version)'
+arch=('any')
+url='http://tt-rss.org/redmine/'
+license=('GPL')
+depends=('php')
+makeodepends=('git')
+conflicts=('tt-rss')
+provide=('tt-rss')
+optdepends=('mysql' 'postgresql' 'php-curl')
+install=tt-rss.install
+source=("$_gitname"::'git://github.com/gothfox/Tiny-Tiny-RSS.git'
+ service)
+sha256sums=('SKIP'
+ '8c33ab29cdb2eda25724e738ed04cb472a7fec0a9edca45729f29b17c46e55df')
+options=(!strip)
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ # Use the tag of the last commit
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ _instdir="$pkgdir"/usr/share/webapps/$pkgname
+
+ install -d "$_instdir"
+ cp -ra * "$_instdir/"
+ rm -rf "$_instdir"/debian
+
+ install -d "$pkgdir"/etc/webapps/tt-rss
+ install -gm640 -g http config.php-dist "$pkgdir"/etc/webapps/tt-rss/config.php-dist
+ ln -s /etc/webapps/tt-rss/config.php "$_instdir"/config.php
+
+ install -d "$pkgdir"/var/lib/tt-rss
+ mv "$_instdir"/{lock,feed-icons,cache} "$pkgdir"/var/lib/tt-rss
+ ln -s /var/lib/tt-rss/lock "$_instdir"/lock
+ ln -s /var/lib/tt-rss/feed-icons "$_instdir"/feed-icons
+ ln -s /var/lib/tt-rss/cache "$_instdir"/cache
+ chown -R 33:33 "$pkgdir"/var/lib/tt-rss
+ chmod -R 777 "$pkgdir"/var/lib/tt-rss/*
+
+ install -Dm644 "$srcdir"/service "$pkgdir"/usr/lib/systemd/system/tt-rss.service
+}
diff --git a/service b/service
new file mode 100644
index 000000000000..1671a5c4851a
--- /dev/null
+++ b/service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Tiny Tiny RSS feeds update daemon
+After=network.target
+After=mysqld.service
+After=postgresql.service
+
+[Service]
+ExecStart=/usr/bin/php /usr/share/webapps/tt-rss-git/update.php --daemon
+User=http
+StandardOutput=syslog
+
+[Install]
+WantedBy=multi-user.target
diff --git a/tt-rss.install b/tt-rss.install
new file mode 100644
index 000000000000..f4bc290b11ba
--- /dev/null
+++ b/tt-rss.install
@@ -0,0 +1,4 @@
+post_upgrade() {
+ echo "===> Update config.php with new configuration data from config.php-dist if necessary."
+ echo " Update CONFIG_VERSION to the new version afterwards."
+}