summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuke Arms2022-08-01 22:57:01 +1000
committerLuke Arms2022-08-01 23:04:37 +1000
commit23792a25a82d1720b6849bfa7e4b24c85d9fd584 (patch)
tree116dd281eafd8e8d4b5e93f47d9b39395885f855
downloadaur-23792a25a82d1720b6849bfa7e4b24c85d9fd584.tar.gz
Initial commit
- Based on extra/adobe-source-code-pro-fonts - Unchanged aside from `pkgname`, `provides`, and installed font format
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD21
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4475e557cf5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = ttf-adobe-source-code-pro-fonts
+ pkgdesc = Monospaced font family for user interface and coding environments
+ pkgver = 2.038ro+1.058it+1.018var
+ pkgrel = 1
+ url = https://adobe-fonts.github.io/source-code-pro/
+ arch = any
+ license = custom
+ provides = adobe-source-code-pro-fonts=2.038ro+1.058it+1.018var
+ source = source-code-pro-2.038R-ro-1.058R-it-1.018R-VAR.tar.gz::https://github.com/adobe-fonts/source-code-pro/archive/2.038R-ro/1.058R-it/1.018R-VAR.tar.gz
+ sha256sums = d8f879fefd66ecb7291ea2d73984b9c0a97fb499424e58290ba6b81787d0c725
+
+pkgname = ttf-adobe-source-code-pro-fonts
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..091d90939cd4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d272579c289a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Luke Arms <luke@arms.to>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+
+pkgname=ttf-adobe-source-code-pro-fonts
+pkgver=2.038ro+1.058it+1.018var
+pkgrel=1
+pkgdesc="Monospaced font family for user interface and coding environments"
+url="https://adobe-fonts.github.io/source-code-pro/"
+arch=(any)
+license=(custom)
+provides=("adobe-source-code-pro-fonts=$pkgver")
+_relver=2.038R-ro/1.058R-it/1.018R-VAR
+_tarname=source-code-pro-${_relver//\//-}
+source=("$_tarname.tar.gz::https://github.com/adobe-fonts/source-code-pro/archive/$_relver.tar.gz")
+sha256sums=('d8f879fefd66ecb7291ea2d73984b9c0a97fb499424e58290ba6b81787d0c725')
+
+package() {
+ cd $_tarname
+ install -Dt "$pkgdir/usr/share/fonts/${pkgname%-fonts}" -m644 TTF/*.ttf VAR/*.ttf
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 LICENSE.md
+}