summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohann Gründl2019-01-15 16:19:50 +0100
committerJohann Gründl2019-01-15 16:19:50 +0100
commit909fba674305efb79fcba25ba544aae6e8259211 (patch)
treefc47a01b54561117182b976f1d86d8cc3fbc0c91
downloadaur-909fba674305efb79fcba25ba544aae6e8259211.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD41
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..28964776a39b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-adobe-source-fonts
+ pkgdesc = TTF versions of Adobe's Source fonts (includes non-variable versions of Source Sans Pro, Source Serif Pro, and Source Code Pro).
+ pkgver = 2.045R+ro+1.095R+it+2.010R+ro+1.010R+it+2.030R+ro+1.050R+it
+ pkgrel = 2
+ url = https://github.com/adobe-fonts
+ arch = any
+ license = custom
+ source = source-sans-pro-2.045R-ro-1.095R-it.tar.gz::https://github.com/adobe-fonts/source-sans-pro/archive/2.045R-ro/1.095R-it.tar.gz
+ source = source-serif-pro-2.010R-ro-1.010R-it.tar.gz::https://github.com/adobe-fonts/source-serif-pro/archive/2.010R-ro/1.010R-it.tar.gz
+ source = source-code-pro-2.030R-ro-1.050R-it.tar.gz::https://github.com/adobe-fonts/source-code-pro/archive/2.030R-ro/1.050R-it.tar.gz
+ sha256sums = 01e78d7ff451545ff1eec6cf14b28f62135e430a7ba80d74a90efd5334fef7eb
+ sha256sums = 1266bbb787ef5cec53303728c9ac38f52b31a8476f9ebbf5477a5782f1c76255
+ sha256sums = a4e4dd59b8e0a436b934f0f612c2e91b5932910c6d1c3b7d1a5a9f389c86302b
+
+pkgname = ttf-adobe-source-fonts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0adc5b903025
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Johann Gründl <mail@johanngruendl.at>
+
+pkgname=ttf-adobe-source-fonts
+_relver_sans=2.045R-ro/1.095R-it
+_relver_serif=2.010R-ro/1.010R-it
+_relver_code=2.030R-ro/1.050R-it
+pkgver=${_relver_sans//[\-\/]/+}+${_relver_serif//[\-\/]/+}+${_relver_code//[\-\/]/+}
+_sans=source-sans-pro
+_serif=source-serif-pro
+_code=source-code-pro
+_tarname_sans=${_sans}-${_relver_sans//\//-}
+_tarname_serif=${_serif}-${_relver_serif//\//-}
+_tarname_code=${_code}-${_relver_code//\//-}
+pkgrel=2
+pkgdesc="TTF versions of Adobe's Source fonts (includes non-variable versions of Source Sans Pro, Source Serif Pro, and Source
+Code Pro)."
+url="https://github.com/adobe-fonts"
+arch=(any)
+license=(custom)
+source=("$_tarname_sans.tar.gz::https://github.com/adobe-fonts/$_sans/archive/$_relver_sans.tar.gz"
+"$_tarname_serif.tar.gz::https://github.com/adobe-fonts/$_serif/archive/$_relver_serif.tar.gz"
+"$_tarname_code.tar.gz::https://github.com/adobe-fonts/$_code/archive/$_relver_code.tar.gz"
+)
+sha256sums=('01e78d7ff451545ff1eec6cf14b28f62135e430a7ba80d74a90efd5334fef7eb'
+'1266bbb787ef5cec53303728c9ac38f52b31a8476f9ebbf5477a5782f1c76255'
+'a4e4dd59b8e0a436b934f0f612c2e91b5932910c6d1c3b7d1a5a9f389c86302b')
+
+package() {
+ cd ./$_tarname_sans
+ install -d "$pkgdir/usr/share/fonts/${pkgname}"
+ install -t "$pkgdir/usr/share/fonts/${pkgname}" -m644 TTF/*.ttf
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE-sans"
+ cd ../$_tarname_serif
+ install -d "$pkgdir/usr/share/fonts/${pkgname}"
+ install -t "$pkgdir/usr/share/fonts/${pkgname}" -m644 TTF/*.ttf
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE-serif"
+ cd ../$_tarname_code
+ install -d "$pkgdir/usr/share/fonts/${pkgname}"
+ install -t "$pkgdir/usr/share/fonts/${pkgname}" -m644 TTF/*.ttf
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE-code"
+}