summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjogrue2020-11-22 16:52:45 +0100
committerjogrue2020-11-22 16:52:45 +0100
commitbabac445ac45fa96c095b0e86c53d8a9af0205df (patch)
treedda12cad2bcf996e8b00be62b05e46b402318c18
parent294a56f70055c7681c552278e824ecbc05a84234 (diff)
downloadaur-babac445ac45fa96c095b0e86c53d8a9af0205df.tar.gz
Now the package includes the variable fonts as well.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af739b968365..54f5ca9e1df6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ttf-adobe-source-fonts
- pkgdesc = TTF versions of Adobe's Source fonts (includes non-variable versions of Source Sans Pro, Source Serif Pro, and Source Code Pro). Now includes Source Sans Pro (3.006R) and Source Sans 3 (3.028R).
- pkgver = 3.028R+3.001R+2.032R+ro+1.052R+it
+ pkgdesc = TTF versions of Adobe's Source fonts (includes variable and non-variable versions of Source Sans Pro, Source Serif Pro, and Source Code Pro). Now includes Source Sans Pro (3.006R) and Source Sans 3 (3.028R).
+ pkgver = 3.028R+3.001R+2.032R+ro+1.052R+it+1.012R+VAR
pkgrel = 5
url = https://github.com/adobe-fonts
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 87dada8f3075..f89fe2c9e5a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,7 @@ pkgname=ttf-adobe-source-fonts
_relver_sans3=3.028R
_relver_sanspro=3.006R
_relver_serif=3.001R
-_relver_code=2.032R-ro/1.052R-it
-_relver_code_var=1.012R-VAR
+_relver_code=2.032R-ro/1.052R-it/1.012R-VAR
pkgver=${_relver_sans3//[\-\/]/+}+${_relver_serif//[\-\/]/+}+${_relver_code//[\-\/]/+}
_sans=source-sans-pro
_serif=source-serif-pro
@@ -13,9 +12,9 @@ _code=source-code-pro
_tarname_sans3=${_sans}-${_relver_sans3//\//-}
_tarname_sanspro=${_sans}-${_relver_sanspro//\//-}
_tarname_serif=${_serif}-${_relver_serif//\//-}
-_tarname_code=${_code}-${_relver_code//\//-}-${_relver_code_var//\//-}
+_tarname_code=${_code}-${_relver_code//\//-}
pkgrel=5
-pkgdesc="TTF versions of Adobe's Source fonts (includes non-variable versions of Source Sans Pro, Source Serif Pro, and Source
+pkgdesc="TTF versions of Adobe's Source fonts (includes variable and non-variable versions of Source Sans Pro, Source Serif Pro, and Source
Code Pro). Now includes Source Sans Pro (3.006R) and Source Sans 3 (3.028R)."
url="https://github.com/adobe-fonts"
arch=(any)
@@ -26,7 +25,7 @@ source=(
"$_tarname_sans3.tar.gz::https://github.com/adobe-fonts/$_sans/archive/$_relver_sans3.tar.gz"
"$_tarname_sanspro.tar.gz::https://github.com/adobe-fonts/$_sans/archive/$_relver_sanspro.tar.gz"
"$_tarname_serif.tar.gz::https://github.com/adobe-fonts/$_serif/archive/$_relver_serif.tar.gz"
-"$_tarname_code.tar.gz::https://github.com/adobe-fonts/$_code/archive/$_relver_code/$_relver_code_var.tar.gz"
+"$_tarname_code.tar.gz::https://github.com/adobe-fonts/$_code/archive/$_relver_code.tar.gz"
)
sha256sums=(
'12faf267e40f1be46daf44afce47facd6efb996e2f2f5abe0a3dde161d54e251'
@@ -39,17 +38,21 @@ package() {
cd ./$_tarname_sans3
install -d "$pkgdir/usr/share/fonts/${pkgname}"
install -t "$pkgdir/usr/share/fonts/${pkgname}" -m644 TTF/*.ttf
+ install -t "$pkgdir/usr/share/fonts/${pkgname}" -m644 VAR/*.ttf
install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE-sans3"
cd ../$_tarname_sanspro
install -d "$pkgdir/usr/share/fonts/${pkgname}"
install -t "$pkgdir/usr/share/fonts/${pkgname}" -m644 TTF/*.ttf
+ install -t "$pkgdir/usr/share/fonts/${pkgname}" -m644 VAR/*.ttf
install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE-sans-pro"
cd ../$_tarname_serif
install -d "$pkgdir/usr/share/fonts/${pkgname}"
install -t "$pkgdir/usr/share/fonts/${pkgname}" -m644 TTF/*.ttf
+ install -t "$pkgdir/usr/share/fonts/${pkgname}" -m644 VAR/*.ttf
install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE-serif"
cd ../$_tarname_code
install -d "$pkgdir/usr/share/fonts/${pkgname}"
install -t "$pkgdir/usr/share/fonts/${pkgname}" -m644 TTF/*.ttf
+ install -t "$pkgdir/usr/share/fonts/${pkgname}" -m644 VAR/*.ttf
install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE-code"
}