summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2018-05-28 11:00:39 -0600
committerBrian Bidulock2018-05-28 11:00:39 -0600
commit0e5da92e9e1b2c058ad9c0900129f25757dedcdb (patch)
tree6b9a37fb148de13edcbfe8732b3a7b8f31afdebf
parentb457372d035376ab255677814dea42f2a60a9d83 (diff)
downloadaur-0e5da92e9e1b2c058ad9c0900129f25757dedcdb.tar.gz
deb is automatically extracted now
-rw-r--r--.SRCINFO5
-rw-r--r--LICENSE16
-rw-r--r--PKGBUILD15
3 files changed, 24 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf3cce1731ae..56811631245a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = ttf-aenigma
pkgdesc = 465 free TrueType fonts by Brian Kent
pkgver = 20080510
- pkgrel = 3
+ pkgrel = 4
url = http://www.aenigmafonts.com
- install = ttf-aenigma.install
arch = any
- license = Freeware
+ license = custom
makedepends = p7zip
depends = fontconfig
depends = xorg-font-utils
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..dac8f622b7ab
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,16 @@
+DISCLAIMER
+ŻŻŻŻŻŻŻŻŻŻ
+-The font(s) in this zip file were created by me (Brian Kent). All
+of my Fonts are Freeware, you can use them any way you want to
+(Personal use, Commercial use, or whatever).
+
+-If you have a Font related site and would like to offer my fonts on
+your site, go right ahead. All I ask is that you keep this text file
+intact with the Font.
+
+-You may not Sell or Distribute my Fonts for profit or alter the font
+file(s) [.ttf .fon] in any way without asking me first. I can be
+reached at:
+aefonts[AT]frontiernet[DOT]net
+
+(make sure you replace the [AT] and [DOT] with the proper characters) .
diff --git a/PKGBUILD b/PKGBUILD
index 66da48902035..ef70774f2241 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,27 @@
-# Maintainer: Patrick Melo <patrick@patrickmelo.eti.br>
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=ttf-aenigma
pkgver=20080510
-pkgrel=3
+pkgrel=4
pkgdesc="465 free TrueType fonts by Brian Kent"
arch=('any')
url="http://www.aenigmafonts.com"
-license=('Freeware')
+license=('custom')
depends=('fontconfig' 'xorg-font-utils')
makedepends=('p7zip')
-install=$pkgname.install
source=('http://ftp.debian.org/debian/pool/main/t/ttf-aenigma/ttf-aenigma_0.0.20080510.dfsg-2_all.deb')
md5sums=('957332d9c605982b88f0a8f73f73b6c9')
build() {
- echo "Extracting DEB..."
- cd "$startdir"
- 7z x "$startdir/ttf-aenigma_0.0.20080510.dfsg-1_all.deb" -o"$srcdir" -y > /dev/null
echo "Extracting TAR..."
- cd "$srcdir"
- tar -xf "data.tar" > /dev/null
+ tar xzf "data.tar.gz" > /dev/null
}
package() {
cd "$srcdir/usr/share/fonts/truetype/aenigma"
mkdir -p "$pkgdir/usr/share/fonts/TTF/"
install -m644 *.ttf "$pkgdir/usr/share/fonts/TTF/"
+ cd "$srcdir"
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
}