summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarvettFox962019-04-07 12:18:38 +0800
committerHarvettFox962019-04-07 12:18:38 +0800
commitc606f9c7f4cb3fccf1d8087fcae4b70548a9df16 (patch)
tree15606dafb4f7d78c3936bbaa48fd84c4c8c60589
downloadaur-c606f9c7f4cb3fccf1d8087fcae4b70548a9df16.tar.gz
Initial commit.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..044d9543df3a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ttf-aireexterior
+ pkgdesc = A geometric sans serif typeface based on the title screen of the 1959 film Plan 9 from Outer Space, superseded from Aero Matics.
+ pkgver = 20190407.01
+ pkgrel = 1
+ url = https://notabug.org/HarvettFox96/ttf-aireexterior
+ arch = any
+ license = CC0-1.0
+ depends = fontconfig
+ depends = unzip
+ depends = xorg-font-utils
+ depends = xorg-fonts-encodings
+ source = AireExterior-20190407.01.zip::https://notabug.org/attachments/9a1a77c5-fc8f-4ad4-9247-0dc957852cc6
+ source = AireExterior-20190407.01.zip.sig::https://notabug.org/attachments/27f1acca-9e89-49be-be26-d6a9ea8e45bb
+ validpgpkeys = 30E2144356008681839AE9C192F8F52D258B63E6
+ validpgpkeys = 4C565E3C3DB4DE43785F0DA9B627DC6AB09D9B83
+ sha512sums = 066dad662d36bcc0079f3a678b6902008e2c492e53bd122d90b4d2715bbdcffe355b4e63fce1a5a33365e64193ddd7216f270fa0fa96cbe0889e54071da4b193
+ sha512sums = SKIP
+
+pkgname = ttf-aireexterior
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00416abe4832
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jayvee Enaguas <harvettfox96@airmail.cc>
+
+pkgname=ttf-aireexterior
+pkgver=20190407.01
+pkgrel=1
+pkgdesc="A geometric sans serif typeface based on the title screen of the 1959 film Plan 9 from Outer Space, superseded from Aero Matics."
+url="https://notabug.org/HarvettFox96/${pkgname}"
+license=("CC0-1.0")
+arch=("any")
+depends=("fontconfig" "unzip" "xorg-font-utils" "xorg-fonts-encodings")
+source=("AireExterior-${pkgver}.zip::https://notabug.org/attachments/9a1a77c5-fc8f-4ad4-9247-0dc957852cc6"
+ "AireExterior-${pkgver}.zip.sig::https://notabug.org/attachments/27f1acca-9e89-49be-be26-d6a9ea8e45bb")
+sha512sums=("066dad662d36bcc0079f3a678b6902008e2c492e53bd122d90b4d2715bbdcffe355b4e63fce1a5a33365e64193ddd7216f270fa0fa96cbe0889e54071da4b193"
+ "SKIP")
+validpgpkeys=("30E2144356008681839AE9C192F8F52D258B63E6"
+ "4C565E3C3DB4DE43785F0DA9B627DC6AB09D9B83")
+
+prepare() {
+ sed -e 's/\r//g' LICENSE.txt > LICENSE;
+}
+
+package() {
+ install -dm755 "${pkgdir}/usr/share/fonts/TTF/";
+ install -Dm644 *.ttf "${pkgdir}/usr/share/fonts/TTF/";
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE";
+ rm -frv "${srcdir}/"*;
+}