summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Dubois2017-05-10 09:16:17 -0400
committerErik Dubois2017-05-10 09:16:17 -0400
commit000bf0cf755c1848ba266054990d1dd6e2686c77 (patch)
tree17a910f1f31a6bc31f7664c1bc92c5a46c5e8821
downloadaur-000bf0cf755c1848ba266054990d1dd6e2686c77.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--40-alef.conf12
-rw-r--r--90-tt-alef.conf26
-rw-r--r--PKGBUILD37
4 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95ff718b3ad1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed May 10 13:16:06 UTC 2017
+pkgbase = ttf-alef-ibx
+ pkgdesc = Alef is an open source multiscript web-font.
+ pkgver = 1.001
+ pkgrel = 6
+ url = http://alef.hagilda.com/
+ arch = any
+ groups = infinality-bundle-fonts-extra
+ license = custom:OFL
+ depends = fontconfig
+ source = http://alef.hagilda.com/Alef.zip
+ source = 40-alef.conf
+ source = 90-tt-alef.conf
+ sha1sums = 7516804f6b3db78d0251159142a8c7904bbf4e82
+ sha1sums = c10bfbc407205e651eace7b767e045048cf035c8
+ sha1sums = 1ee56d7efec80581dc7d495bbd7e0b9874605ff2
+
+pkgname = ttf-alef-ibx
+
diff --git a/40-alef.conf b/40-alef.conf
new file mode 100644
index 000000000000..796eb35e617d
--- /dev/null
+++ b/40-alef.conf
@@ -0,0 +1,12 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+
+ <alias>
+ <family>Alef</family>
+ <default>
+ <family>sans-serif</family>
+ </default>
+ </alias>
+
+</fontconfig>
diff --git a/90-tt-alef.conf b/90-tt-alef.conf
new file mode 100644
index 000000000000..449ac632edbd
--- /dev/null
+++ b/90-tt-alef.conf
@@ -0,0 +1,26 @@
+<?xml version='1.0'?>
+<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
+<fontconfig>
+
+ <match target="font">
+ <test name="force_autohint">
+ <bool>false</bool>
+ </test>
+ <test name="family">
+ <string>Alef</string>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+</fontconfig>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f021009b3e1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: bohoomil <@zoho.com>
+
+pkgname=ttf-alef-ibx
+pkgver=1.001
+pkgrel=6
+depends=('fontconfig')
+pkgdesc="Alef is an open source multiscript web-font."
+url="http://alef.hagilda.com/"
+arch=('any')
+license=('custom:OFL')
+groups=('infinality-bundle-fonts-extra')
+source=("http://alef.hagilda.com/Alef.zip"
+ 40-alef.conf
+ 90-tt-alef.conf)
+sha1sums=('7516804f6b3db78d0251159142a8c7904bbf4e82'
+ 'c10bfbc407205e651eace7b767e045048cf035c8'
+ '1ee56d7efec80581dc7d495bbd7e0b9874605ff2')
+
+package() {
+
+ install -D -m644 OFL-license.txt \
+ "${pkgdir}"/usr/share/licenses/"${pkgname}"/COPYING
+
+ install -d -m755 "${pkgdir}"/usr/share/fonts/"${pkgname}"
+ install -m644 TTF/*.ttf "${pkgdir}"/usr/share/fonts/"${pkgname}"
+
+ install -D -m644 40-alef.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/40-alef.conf
+ install -D -m644 90-tt-alef.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/90-tt-alef.conf
+
+ install -m755 -d "${pkgdir}"/etc/fonts/conf.d
+ cd "${pkgdir}"/etc/fonts/conf.d
+ ln -s ../conf.avail/40-alef.conf .
+ ln -s ../conf.avail/90-tt-alef.conf .
+}
+