summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-05-03 15:45:46 -0400
committerAlex Whitt2017-05-03 15:45:46 -0400
commite309952245cc55c3d028ffb7d8204057b53f6e62 (patch)
tree3c5aba5884dd32dad7b9a4ddc107c7539bdc85ff
downloadaur-e309952245cc55c3d028ffb7d8204057b53f6e62.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16ae703c0db9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed May 3 19:45:23 UTC 2017
+pkgbase = ttf-all-the-icons
+ pkgdesc = Icon font for all-the-icons.el (A utility package to collect various Icon Fonts and propertize them within Emacs.)
+ pkgver = 2.5.2
+ pkgrel = 1
+ url = https://github.com/domtronn/all-the-icons.el
+ arch = any
+ license = MIT
+ makedepends = woff2-git
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = ttf-all-the-icons-2.5.2.tar.gz::https://github.com/domtronn/all-the-icons.el/archive/2.5.2.tar.gz
+ sha256sums = SKIP
+
+pkgname = ttf-all-the-icons
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1db16598825
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+_pkgsrcname=all-the-icons.el
+_pkgmaintainer=domtronn
+_pkgdestdirname=all-the-icons
+_versionprefix=
+pkgver=2.5.2
+pkgrel=1
+pkgdesc="Icon font for all-the-icons.el (A utility package to collect various Icon Fonts and propertize them within Emacs.)"
+pkgname=ttf-${_pkgdestdirname}
+arch=(any)
+url="https://github.com/${_pkgmaintainer}/${_pkgsrcname}"
+license=('MIT')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+makedepends=('woff2-git')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/${_pkgmaintainer}/${_pkgsrcname}/archive/${_versionprefix}${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+package() {
+ cd "${srcdir}/${_pkgsrcname}-${pkgver}/"
+ install -d $pkgdir/usr/share/fonts/TTF/
+ install -m644 fonts/${_pkgdestdirname}.ttf "$pkgdir/usr/share/fonts/TTF/${_pkgdestdirname}.ttf"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}