summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjesuschroist2017-09-03 15:14:18 +0200
committerjesuschroist2017-09-03 15:14:18 +0200
commit3cd7ada31a5f795312e3034565fcbc39ccbf743f (patch)
tree8e2af0a3755afce49df34be7e9c9e196ffbf607f
downloadaur-3cd7ada31a5f795312e3034565fcbc39ccbf743f.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
-rw-r--r--ttf.install15
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af6c515fead5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ttf-alte-haas-grotesk
+ pkgdesc = A typeface that looks like a helvetica printed in an old Muller-Brockmann book.
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.yannlecoroller.com/
+ install = ttf.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://dl.1001fonts.com/alte-haas-grotesk.zip
+ md5sums = 9bdbc794a33acd478f2261f112ba971b
+
+pkgname = ttf-alte-haas-grotesk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ffc4df9e661
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: jesuschroist <chris@qlab.pro>
+
+pkgname=ttf-alte-haas-grotesk
+pkgver=1.0
+pkgrel=1
+pkgdesc="A typeface that looks like a helvetica printed in an old Muller-Brockmann book."
+arch=('any')
+url="http://www.yannlecoroller.com/"
+license=('custom')
+depends=('fontconfig' 'xorg-font-utils')
+install=ttf.install
+source=(http://dl.1001fonts.com/alte-haas-grotesk.zip)
+md5sums=('9bdbc794a33acd478f2261f112ba971b')
+
+package() {
+ cd "$srcdir"
+ install -dm755 "$pkgdir/usr/share/fonts/TTF"
+ install -Dm644 AlteHaasGroteskRegular.ttf "$pkgdir/usr/share/fonts/TTF"
+ install -Dm644 AlteHaasGroteskBold.ttf "$pkgdir/usr/share/fonts/TTF"
+ install -Dm644 Alte\ Haas\ Grotesk\ licence.rtf "$pkgdir/usr/share/licenses/$pkgname/Alte Haas Grotesk licence.rtf"
+}
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..33b7d65490db
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "==> Rebuilding font cache... "
+ fc-cache -f &> /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}