summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen2015-06-09 19:33:03 +0800
committerAllen2015-06-09 19:33:03 +0800
commitc462253dc9e4fe84baa8061640685738e1c64e86 (patch)
treed90d38f9bd8173b2d9602c5b7c732de9e4aa28a2
downloadaur-c462253dc9e4fe84baa8061640685738e1c64e86.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
-rw-r--r--ttf-ancient-semitic.install15
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..809281fd8be6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-ancient-semitic
+ pkgdesc = Ancient Semitic fonts including Samaritan
+ pkgver = 0.06
+ pkgrel = 2
+ url = http://culmus.sourceforge.net
+ install = ttf-ancient-semitic.install
+ arch = any
+ license = GPL2
+ depends = fontconfig
+ depends = xorg-fonts-alias
+ depends = xorg-font-utils
+ depends = xorg-fonts-encodings
+ source = http://downloads.sourceforge.net/culmus/AncientSemiticFonts-0.06-1.TTF.tgz
+ md5sums = 9b7a71347ba069e0d0d529650b8434e7
+
+pkgname = ttf-ancient-semitic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85f937bfb0f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Allen Choong <allencch at hotmail dot com>
+
+pkgname=ttf-ancient-semitic
+pkgver=0.06
+pkgrel=2
+pkgdesc="Ancient Semitic fonts including Samaritan"
+arch=('any')
+url="http://culmus.sourceforge.net"
+license=('GPL2')
+depends=('fontconfig' 'xorg-fonts-alias' 'xorg-font-utils' 'xorg-fonts-encodings')
+install=${pkgname}.install
+source=(
+ "http://downloads.sourceforge.net/culmus/AncientSemiticFonts-${pkgver}-1.TTF.tgz"
+)
+md5sums=('9b7a71347ba069e0d0d529650b8434e7')
+
+package() {
+ mkdir -p $pkgdir/usr/share/fonts/TTF
+ cp $srcdir/AncientSemiticFonts-${pkgver}-1.TTF/fonts/*.ttf $pkgdir/usr/share/fonts/TTF
+}
+
diff --git a/ttf-ancient-semitic.install b/ttf-ancient-semitic.install
new file mode 100644
index 000000000000..1aae7e73bcb5
--- /dev/null
+++ b/ttf-ancient-semitic.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -fs >/dev/null
+ mkfontscale /usr/share/fonts/TTF /usr/share/fonts/Type1
+ mkfontdir /usr/share/fonts/TTF /usr/share/fonts/Type1
+ echo "done"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}