summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2013-08-23 16:58:29 +0400
committerAnton Leontiev2015-02-15 07:48:01 +0300
commitd1dbf9c2d98321c6b8ed5b5920bd216e04c799c6 (patch)
tree4af8643b21e3c83d7de2131a0d80da2231f8bfb3
downloadaur-d1dbf9c2d98321c6b8ed5b5920bd216e04c799c6.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD23
-rw-r--r--ttf-andika.install15
4 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b5fc51551b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-andika
+ pkgdesc = A sans serif, Unicode-compliant font designed especially for literacy use
+ pkgver = 1.004
+ pkgrel = 1
+ url = http://scripts.sil.org/andika
+ install = ttf-andika.install
+ arch = any
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ conflicts = ttf-sil-fonts
+ source = andika-1.004.zip::http://scripts.sil.org/cms/scripts/render_download.php?&format=file&media_id=Andika-1.004.zip&filename=Andika-1.004.zip
+ md5sums = f83086975b0fe292dba1749e638ba9f2
+
+pkgname = ttf-andika
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e13b50e119dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Baptiste Grenier <baptiste@bapt.name>
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+pkgname=ttf-andika
+pkgver=1.004
+pkgrel=1
+pkgdesc='A sans serif, Unicode-compliant font designed especially for literacy use'
+url='http://scripts.sil.org/andika'
+arch=('any')
+license=('custom:OFL')
+depends=('fontconfig' 'xorg-font-utils')
+conflicts=('ttf-sil-fonts')
+install=ttf-andika.install
+source=("andika-$pkgver.zip::http://scripts.sil.org/cms/scripts/render_download.php?&format=file&media_id=Andika-$pkgver.zip&filename=Andika-$pkgver.zip")
+md5sums=('f83086975b0fe292dba1749e638ba9f2')
+
+package() {
+ cd "$srcdir/Andika-$pkgver"
+ install -Dm644 Andika-R.ttf "$pkgdir/usr/share/fonts/TTF/AndikaRegular.ttf"
+ install -Dm644 OFL.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README.txt "$pkgdir/usr/share/andika/README"
+ install -m644 FONTLOG.txt "$pkgdir/usr/share/andika/FONTLOG"
+ install -m644 documentation/Andika-features.pdf "$pkgdir/usr/share/andika/Andika-features.pdf"
+}
diff --git a/ttf-andika.install b/ttf-andika.install
new file mode 100644
index 000000000000..7dde94b45180
--- /dev/null
+++ b/ttf-andika.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}