summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-07-06 09:09:40 +0200
committeraksr2015-07-06 09:09:40 +0200
commit8e8ff7e735979814aa4d548ac4ddb73687bcd476 (patch)
tree6e8becfa122c235f830ba0e5dabcc07e93dde9d2
downloadaur-8e8ff7e735979814aa4d548ac4ddb73687bcd476.tar.gz
Start.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
-rw-r--r--ttf.install12
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca79e3c6c40a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-antinoou
+ pkgdesc = A standard font for Coptic.
+ pkgver = 1.0.6
+ pkgrel = 1
+ url = http://www.evertype.com/fonts/coptic/
+ install = ttf.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.evertype.com/fonts/coptic/AntinoouFont.zip
+ md5sums = 30f9ec32a81b3ae3aa7c9a72fa613e39
+ sha1sums = 5b7da0df69c5c8c5831fcb58e9706d36e4b11462
+ sha256sums = d7f961ff2ab5b6c707e4f0a24e8302c7a61c2e2ab2e9880c94a8deb6f5aeff69
+
+pkgname = ttf-antinoou
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8275312630d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=ttf-antinoou
+_pkgname=AntinoouFont
+pkgver=1.0.6
+pkgrel=1
+pkgdesc="A standard font for Coptic."
+arch=('any')
+url="http://www.evertype.com/fonts/coptic/"
+license=('custom')
+depends=('fontconfig' 'xorg-font-utils')
+install=ttf.install
+source=("http://www.evertype.com/fonts/coptic/$_pkgname.zip")
+md5sums=('30f9ec32a81b3ae3aa7c9a72fa613e39')
+sha1sums=('5b7da0df69c5c8c5831fcb58e9706d36e4b11462')
+sha256sums=('d7f961ff2ab5b6c707e4f0a24e8302c7a61c2e2ab2e9880c94a8deb6f5aeff69')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ mkdir -p $pkgdir/usr/share/fonts/TTF
+ install -m644 *.ttf $pkgdir/usr/share/fonts/TTF/
+ install -Dm644 antinoou-licence.txt $pkgdir/usr/share/licenses/$pkgname/license.txt
+}
+
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..61210947bba1
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,12 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -fs >/dev/null
+ mkfontscale /usr/share/fonts/TTF /usr/share/fonts/Type1
+ mkfontdir /usr/share/fonts/TTF /usr/share/fonts/Type1
+ echo "done"
+}
+
+post_upgrade() {
+ post_install
+}
+