summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramoka2020-06-18 14:00:36 -0400
committeramoka2020-06-18 14:00:36 -0400
commite329709226d530d3f1d932bcdf19028923cf4876 (patch)
treec8743de55f1fc0d10c25c94181451efa2ba5d082
downloadaur-e329709226d530d3f1d932bcdf19028923cf4876.tar.gz
first upload
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..478875ee4054
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-archivo-black
+ pkgdesc = Archivo is a grotesque sans serif typeface family from Omnibus Type
+ pkgver = 1.006
+ pkgrel = 1
+ url = https://github.com/Omnibus-Type/ArchivoBlack
+ arch = any
+ license = custom:OFL
+ source = https://raw.githubusercontent.com/Omnibus-Type/ArchivoBlack/master/fonts/ttf/ArchivoBlack-Regular.ttf
+ source = https://raw.githubusercontent.com/Omnibus-Type/ArchivoBlack/master/fonts/ttf/ArchivoBlack-Italic.ttf
+ source = https://raw.githubusercontent.com/Omnibus-Type/ArchivoBlack/master/OFL.txt
+ sha256sums = 3cdaf0609a90ce679499407fc7761f3adb5ae8d3c3237249c2d11f5f095eda7d
+ sha256sums = 721b3c19efaf59c62316b4192a32fbe60856c3f87bf7e4648bab7fdb70926150
+ sha256sums = 000a3db5300ab7645fb1f861061987f7a4320939ae733d5c29aab3df6a281447
+
+pkgname = ttf-archivo-black
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4d11a61f10f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Amanoel Dawod <amoka at amanoel dot com>
+
+pkgname=ttf-archivo-black
+pkgver=1.006
+pkgrel=1
+pkgdesc="Archivo is a grotesque sans serif typeface family from Omnibus Type"
+arch=('any')
+url="https://github.com/Omnibus-Type/ArchivoBlack"
+license=('custom:OFL')
+source=("https://raw.githubusercontent.com/Omnibus-Type/ArchivoBlack/master/fonts/ttf/ArchivoBlack-Regular.ttf"
+ "https://raw.githubusercontent.com/Omnibus-Type/ArchivoBlack/master/fonts/ttf/ArchivoBlack-Italic.ttf"
+ "https://raw.githubusercontent.com/Omnibus-Type/ArchivoBlack/master/OFL.txt")
+sha256sums=('3cdaf0609a90ce679499407fc7761f3adb5ae8d3c3237249c2d11f5f095eda7d'
+ '721b3c19efaf59c62316b4192a32fbe60856c3f87bf7e4648bab7fdb70926150'
+ '000a3db5300ab7645fb1f861061987f7a4320939ae733d5c29aab3df6a281447')
+
+package() {
+ install -d "${pkgdir}"/usr/share/fonts/TTF
+ install -m644 *.ttf "${pkgdir}"/usr/share/fonts/TTF
+ install -D -m644 OFL.txt "$pkgdir/usr/share/licenses/$pkgname/OFL.txt"
+}