summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-08-21 23:31:25 -0500
committerLuis Martinez2021-08-21 23:31:25 -0500
commit9175724ee6ec66a0a18603f5c59bb1acbf6eaa20 (patch)
treefd86e1d452947c77096857817b9c9bbac133f2f2
parent01b4ada4a7f2e8d99be12df9a8ebfa8393058ee5 (diff)
downloadaur-9175724ee6ec66a0a18603f5c59bb1acbf6eaa20.tar.gz
fix package
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 14 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af2c73e0b046..a49c1f1a58e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = ttf-autour-one
- pkgdesc = Autour One is inspired by handwritten letters on Ludwig Hohlwein posters.
+ pkgdesc = A font inspired by handwritten letters on Ludwig Hohlwein posters.
pkgver = 1
- pkgrel = 1
+ pkgrel = 2
url = https://fonts.google.com/specimen/Autour+One
arch = any
license = OFL
- depends = fontconfig
- source = https://fonts.google.com/download?family=Autour%20One
- md5sums = 038165a26c5a19e84bf7877fd746f279
+ provides = ttf-font
+ source = ttf-autour-one-1.zip::https://fonts.google.com/download?family=Autour%20One
+ sha256sums = 2284dc6172dc70edf6185354757a405677bc9d27581e6991eaaed5ae09050c78
pkgname = ttf-autour-one
-
diff --git a/PKGBUILD b/PKGBUILD
index 97ce63feed1e..0091c10f7326 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
-# Maintainer: Chocopwowwa <chocopowwwa@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Chocopwowwa <chocopowwwa@gmail.com>
# Source: https://git.archlinux.org/svntogit/community.git/plain/trunk/PKGBUILD?h=packages/ttf-roboto
pkgname=ttf-autour-one
pkgver=1
-pkgrel=1
-
-pkgdesc="Autour One is inspired by handwritten letters on Ludwig Hohlwein posters."
+pkgrel=2
+pkgdesc="A font inspired by handwritten letters on Ludwig Hohlwein posters."
url='https://fonts.google.com/specimen/Autour+One'
arch=('any')
license=('OFL')
-
-depends=('fontconfig')
-
-source=(https://fonts.google.com/download?family=Autour%20One)
-md5sums=('038165a26c5a19e84bf7877fd746f279')
+provides=('ttf-font')
+source=("$pkgname-$pkgver.zip::https://fonts.google.com/download?family=Autour%20One")
+sha256sums=('2284dc6172dc70edf6185354757a405677bc9d27581e6991eaaed5ae09050c78')
package() {
- install -Dm644 OFL.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 *.ttf -t "$pkgdir"/usr/share/fonts/TTF
+ install -Dm 644 *.ttf -t "$pkgdir/usr/share/fonts/TTF/"
+ install -Dm 644 OFL.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
}