summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmile Pesik2015-07-17 11:20:51 +0100
committerEmile Pesik2015-07-17 11:20:51 +0100
commitefe3149ee8400c5722fa134d2b69b2e0d0b87220 (patch)
tree1bc0420273653d2aafd82f34fd06eb4bcbbe85a6
downloadaur-efe3149ee8400c5722fa134d2b69b2e0d0b87220.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
-rw-r--r--ttf.install17
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de2daef77500
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-beteckna
+ pkgdesc = A geometric sans serif typeface inspired by the popular Futura
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://web.archive.org/web/20130517030302/http://gnu.ethz.ch/linuks.mine.nu/beteckna/
+ install = ttf.install
+ arch = any
+ license = GPL3
+ makedepends = fontforge
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://web.archive.org/web/20130517030302/http://gnu.ethz.ch/linuks.mine.nu/beteckna/beteckna-0.4.tar.gz
+ sha256sums = 7b2d02e82422c0d4f5550cb8c3679e0549343bad49b261673c04f44dda8ee307
+
+pkgname = ttf-beteckna
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab69042d8524
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: TDY <tdy@archlinux.info>
+
+pkgname=ttf-beteckna
+pkgver=0.4
+pkgrel=1
+pkgdesc="A geometric sans serif typeface inspired by the popular Futura"
+arch=('any')
+url="https://web.archive.org/web/20130517030302/http://gnu.ethz.ch/linuks.mine.nu/beteckna/"
+license=('GPL3')
+depends=('fontconfig' 'xorg-font-utils')
+makedepends=('fontforge')
+install=ttf.install
+source=(https://web.archive.org/web/20130517030302/http://gnu.ethz.ch/linuks.mine.nu/beteckna/beteckna-$pkgver.tar.gz)
+sha256sums=('7b2d02e82422c0d4f5550cb8c3679e0549343bad49b261673c04f44dda8ee307')
+
+build() {
+ cd "$srcdir/${pkgname/*-}-$pkgver"
+ fontforge -script sfd2ttf.ff *.sfd 2> /dev/null
+}
+
+package() {
+ cd "$srcdir/${pkgname/*-}-$pkgver"
+ install -dm755 "$pkgdir/usr/share/fonts/TTF"
+ install -m644 *.ttf "$pkgdir/usr/share/fonts/TTF"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..7370041e234b
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,17 @@
+post_install() {
+ echo -n "==> Rebuilding font cache... "
+ fc-cache -f &> /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+# vim:set ts=2 sw=2 et: