summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Long2019-06-18 13:21:00 -0500
committerTyler Long2019-06-18 13:21:00 -0500
commit8c4c0873369b632462da9a0641c0203f195d2ea9 (patch)
tree01e096686150d01457eae96ecdc46b523c9b6934
downloadaur-8c4c0873369b632462da9a0641c0203f195d2ea9.tar.gz
added .SRCINFO
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
-rw-r--r--ttf.install15
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..53151d8c871e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-bevan
+ pkgdesc = Bevan is a web font design based on a number of old pre-digital typeface designs.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/vernnobile/BevanFont
+ install = ttf.install
+ arch = any
+ license = custom:OFL
+ depends = fontconfig
+ source = git+https://github.com/vernnobile/BevanFont.git
+ source = ttf.install
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = ttf-bevan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fca270220b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: wafflefrisbee ( dev [at] longfam [dot] org )
+
+pkgname=ttf-bevan
+pkgver=1.0
+pkgrel=1
+pkgdesc="Bevan is a web font design based on a number of old pre-digital typeface designs."
+arch=('any')
+license=('custom:OFL')
+url="https://github.com/vernnobile/BevanFont"
+depends=('fontconfig')
+install=ttf.install
+source=('git+https://github.com/vernnobile/BevanFont.git' 'ttf.install')
+md5sums=('SKIP' 'SKIP')
+
+package () {
+ install -Dm644 ${srcdir}/BevanFont/1.0/Bevan.ttf "${pkgdir}/usr/share/fonts/TTF/Bevan.ttf"
+ install -Dm644 ${srcdir}/BevanFont/1.0/OFL.txt "${pkgdir}/usr/share/licenses/$pkgname/OFL.txt"
+} \ No newline at end of file
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..baec41da9500
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -s
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+} \ No newline at end of file