summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorluxcem2020-02-22 16:35:22 +0100
committerluxcem2020-02-22 16:35:22 +0100
commit87d1038a6e45c13bc080795da443769fde4467d5 (patch)
tree4a7d1f8c9130b41c23bcbb72b7bcc5cabc778b9c
parentfeee83a39af2b18242d33f406a00c96fa6759648 (diff)
downloadaur-87d1038a6e45c13bc080795da443769fde4467d5.tar.gz
Add fontconfig file, restore otf files, add conflicts, provide and depends settings.
-rw-r--r--.SRCINFO10
-rw-r--r--82-charter.conf16
-rw-r--r--PKGBUILD28
3 files changed, 45 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65bfa0eab7b4..4184c4d966a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,18 @@
pkgbase = ttf-bitstream-charter
- pkgdesc = TTF version of a serif typeface designed by Matthew Carter for low resolution devices
+ pkgdesc = A serif typeface designed by Matthew Carter for low resolution devices. Provides OTF, TTF and fontconfig configuration.
pkgver = 1.0
- pkgrel = 2
+ pkgrel = 3
url = https://practicaltypography.com/charter.html
arch = any
license = custom
+ depends = fontconfig
+ provides = ttf-font
+ provides = otf-font
+ conflicts = otf-bitstream-charter
source = http://practicaltypography.com/fonts/charter.zip
+ source = 82-charter.conf
sha256sums = bcddb75c25406def3d461c6f161ce10f3b32433f5b2109fc0716782ff21285b7
+ sha256sums = 0de8093ecf7053865596d39fd1059f049abec480cf7488de366f1db6dc637cc8
pkgname = ttf-bitstream-charter
diff --git a/82-charter.conf b/82-charter.conf
new file mode 100644
index 000000000000..27a2c23ebb83
--- /dev/null
+++ b/82-charter.conf
@@ -0,0 +1,16 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+ <alias>
+ <family>Charter</family>
+ <default>
+ <family>serif</family>
+ </default>
+ </alias>
+ <!-- Some website use Bitstream Charter instead of Charter -->
+ <alias>
+ <family>Bitstream Charter</family>
+ <prefer><family>Charter</family></prefer>
+ <default><family>serif</family></default>
+ </alias>
+</fontconfig>
diff --git a/PKGBUILD b/PKGBUILD
index 899aa1bcc2fa..2204ca163c89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,30 @@
-# Maintainer: David Pflug <david@pflug.email>
+# Maintainer: luxcem <a@luxcem.fr>
+# Contributor: David Pflug <david@pflug.email>
pkgname=ttf-bitstream-charter
pkgver=1.0
-pkgrel=2
-pkgdesc="TTF version of a serif typeface designed by Matthew Carter for low resolution devices"
-arch=('any')
+pkgrel=3
+_conffile=82-charter.conf
+pkgdesc="A serif typeface designed by Matthew Carter for low resolution devices. Provides OTF, TTF and fontconfig configuration."
+arch=("any")
+depends=("fontconfig")
+provides=('ttf-font' 'otf-font')
+conflicts=("otf-bitstream-charter")
url="https://practicaltypography.com/charter.html"
-license=('custom')
-source=("http://practicaltypography.com/fonts/charter.zip")
-sha256sums=('bcddb75c25406def3d461c6f161ce10f3b32433f5b2109fc0716782ff21285b7')
+license=("custom")
+source=("http://practicaltypography.com/fonts/charter.zip" "${_conffile}")
+sha256sums=("bcddb75c25406def3d461c6f161ce10f3b32433f5b2109fc0716782ff21285b7"
+ "0de8093ecf7053865596d39fd1059f049abec480cf7488de366f1db6dc637cc8")
package() {
install -d "${pkgdir}"/usr/share/fonts/TTF
+ install -d "${pkgdir}"/usr/share/fonts/OTF
install -Dm644 "${srcdir}"/charter/ttf/*.ttf "${pkgdir}"/usr/share/fonts/TTF
+ install -Dm644 "${srcdir}"/charter/otf/*.otf "${pkgdir}"/usr/share/fonts/OTF
install -Dm644 "${srcdir}"/charter/license.txt "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+
+ # Install fontconfig file
+ install -d "$pkgdir"/etc/fonts/conf.avail
+ install -Dm644 "$srcdir"/${_conffile} -t "$pkgdir"/etc/fonts/conf.avail/
+ install -d "$pkgdir"/etc/fonts/conf.d
+ ln -rs "$pkgdir"/etc/fonts/conf.avail/${_conffile} "$pkgdir"/etc/fonts/conf.d
}