summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-03-12 11:32:46 +0300
committerCaleb Maclennan2020-03-12 11:32:46 +0300
commitd634a02f1fb95199bc528f5e5b1a6a20f9e546c6 (patch)
treeff8a781634620bdcd0bc2d26b76a8ecdeaebed9c
parent5352651cb4e1562fcf60a32cba81edc1da0fec2d (diff)
downloadaur-d634a02f1fb95199bc528f5e5b1a6a20f9e546c6.tar.gz
Drop obsolete dependencies
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 11 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fa3de76711f..f7255adc4e0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
pkgbase = ttf-blackout
pkgdesc = Eats holes for breakfast lunch and dinner. Inspired by filling in sans-serif newspaper headlines. Continually updated with coffee and music. Makes your work louder than the next person’s.
pkgver = 20160215
- pkgrel = 3
+ pkgrel = 4
url = http://theleagueofmoveabletype.com/blackout
arch = any
groups = lmt-fonts
- license = custom:OFL
- depends = fontconfig
- depends = xorg-fonts-encodings
- depends = xorg-font-utils
+ license = OFL
source = ttf-blackout-20160215.zip::https://github.com/theleagueof/blackout/archive/master.zip
- md5sums = 23ec5900abd2b9f9196cec94ae505315
+ sha256sums = cfc75d15b72e558a3e87bf2cb9f69f09756b5179254e8131ac3d59437f41143b
pkgname = ttf-blackout
diff --git a/PKGBUILD b/PKGBUILD
index de70d568caf0..1ccc7ef942f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,22 @@
# Maintainer: LightDot <lightdot -a-t- g m a i l>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
# Contributor: samæ <samæ at marvid dot fr>
_fnt_name=blackout
pkgname=ttf-$_fnt_name
pkgver=20160215
-pkgrel=3
+pkgrel=4
pkgdesc="Eats holes for breakfast lunch and dinner. Inspired by filling in sans-serif newspaper headlines. Continually updated with coffee and music. Makes your work louder than the next person’s."
arch=('any')
url="http://theleagueofmoveabletype.com/$_fnt_name"
-license=('custom:OFL')
+license=('OFL')
groups=('lmt-fonts')
-depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
source=("$pkgname-$pkgver.zip::https://github.com/theleagueof/$_fnt_name/archive/master.zip")
-md5sums=('23ec5900abd2b9f9196cec94ae505315')
+sha256sums=('cfc75d15b72e558a3e87bf2cb9f69f09756b5179254e8131ac3d59437f41143b')
package() {
- install -Dm644 "$srcdir/$_fnt_name"-master/Blackout\ 2\ AM.ttf "$pkgdir"/usr/share/fonts/TTF/Blackout2AM.ttf
- install -Dm644 "$srcdir/$_fnt_name"-master/Blackout\ Midnight.ttf "$pkgdir"/usr/share/fonts/TTF/BlackoutMidnight.ttf
- install -Dm644 "$srcdir/$_fnt_name"-master/Blackout\ Sunrise.ttf "$pkgdir"/usr/share/fonts/TTF/BlackoutSunrise.ttf
- install -Dm644 "$srcdir/$_fnt_name"-master/Blackout\ Two\ AM.ttf "$pkgdir"/usr/share/fonts/TTF/BlackoutTwoAM.ttf
-
- install -Dm644 "$srcdir/$_fnt_name"-master/Open\ Font\ License.markdown "$pkgdir/usr/share/licenses/$pkgname"/OFL.txt
+ cd "$_fnt_name-master"
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" *.ttf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" Open*.markdown
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" readme.markdown
}
-