summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcus M. Scheunemann2018-06-11 23:38:26 +0100
committerMarcus M. Scheunemann2018-06-11 23:39:40 +0100
commit5479e712e2d2c27b1213b7b8aaa3da1b783f5842 (patch)
tree5d74750eab49f05d3364b1a4f579bf849812bf8e
downloadaur-5479e712e2d2c27b1213b7b8aaa3da1b783f5842.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
-rw-r--r--ttf-bree-serif.install15
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8bae5ebfeabc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-bree-serif
+ pkgdesc = Bree Serif is a font by TypeTogether, an independent type foundry committed to excellence in type design with a focus on editorial use.
+ pkgver = 1.002
+ pkgrel = 1
+ url = https://fonts.google.com/specimen/Bree+Serif
+ install = ttf-bree-serif.install
+ arch = any
+ license = Open Font License
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://raw.githubusercontent.com/google/fonts/master/ofl/breeserif/OFL.txt
+ source = https://raw.githubusercontent.com/google/fonts/master/ofl/breeserif/BreeSerif-Regular.ttf
+ sha256sums = fbe0442a6b1ce162c95e241df76cab5ef2daf6a5ac84ae1a7a6749f32c051098
+ sha256sums = fd080582d70112ef479ba4ddd72407f9a4fcbcec4caa7d29de259b13eeb5f431
+
+pkgname = ttf-bree-serif
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ceabd0d6914c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Marcus M. Scheunemann <find@mms.ai>
+pkgname=ttf-bree-serif
+pkgver=1.002
+pkgrel=1
+depends=('fontconfig' 'xorg-font-utils')
+pkgdesc='Bree Serif is a font by TypeTogether, an independent type foundry committed to excellence in type design with a focus on editorial use.'
+arch=('any')
+url='https://fonts.google.com/specimen/Bree+Serif'
+license=('Open Font License')
+source=('https://raw.githubusercontent.com/google/fonts/master/ofl/breeserif/OFL.txt'
+ 'https://raw.githubusercontent.com/google/fonts/master/ofl/breeserif/BreeSerif-Regular.ttf')
+install=${pkgname}.install
+sha256sums=('fbe0442a6b1ce162c95e241df76cab5ef2daf6a5ac84ae1a7a6749f32c051098'
+ 'fd080582d70112ef479ba4ddd72407f9a4fcbcec4caa7d29de259b13eeb5f431')
+
+package() {
+ cd ${srcdir}
+ install -d ${pkgdir}/usr/share/fonts/TTF/
+ install -m644 *.ttf ${pkgdir}/usr/share/fonts/TTF/
+ install -D -m644 OFL.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/ttf-bree-serif.install b/ttf-bree-serif.install
new file mode 100644
index 000000000000..00ad5153cd82
--- /dev/null
+++ b/ttf-bree-serif.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache ... "
+ fc-cache -sf
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}