summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Wolf2015-06-15 10:57:07 +0200
committerSebastian Wolf2015-06-15 10:57:07 +0200
commit9b4e05792fe6df679acfb18075bf2a781b0d6d34 (patch)
tree2afe1d8c0141031e93fba26b1fdf6049af0eec42
downloadaur-9b4e05792fe6df679acfb18075bf2a781b0d6d34.tar.gz
Updated and migrated to AUR4
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
-rw-r--r--ttf-c64.install15
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d191b243d5a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ttf-c64
+ pkgdesc = The best available C64 TrueType representation to date
+ pkgver = 1.2
+ pkgrel = 1
+ url = http://style64.org/c64-truetype
+ install = ttf-c64.install
+ arch = any
+ license = http://style64.org/c64-truetype/license
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://style64.org/file/C64_TrueType_v1.2-STYLE.zip
+ md5sums = b4e97f5c33671a2dc88a22b16b67b232
+
+pkgname = ttf-c64
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8afa73da964
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Sebastian Wolf <fatmike303 at gmail dot com>
+pkgname=ttf-c64
+pkgver=1.2
+pkgrel=1
+pkgdesc="The best available C64 TrueType representation to date"
+arch=('any')
+url="http://style64.org/c64-truetype"
+license=('http://style64.org/c64-truetype/license')
+depends=('fontconfig' 'xorg-font-utils')
+source=(http://style64.org/file/C64_TrueType_v${pkgver}-STYLE.zip)
+install=$pkgname.install
+md5sums=('b4e97f5c33671a2dc88a22b16b67b232')
+
+package() {
+# mkdir -p $pkgdir/usr/share/fonts/TTF
+ install -D -m644 "${srcdir}/C64_TrueType_v$pkgver-STYLE/fonts/C64_Pro_Mono-STYLE.ttf" "${pkgdir}/usr/share/fonts/TTF/c64_pro_mono.ttf" || return 1
+ install -D -m644 "${srcdir}/C64_TrueType_v$pkgver-STYLE/fonts/C64_Pro-STYLE.ttf" "${pkgdir}/usr/share/fonts/TTF/c64_pro.ttf" || return 1
+ install -D -m644 $srcdir/C64_TrueType_v$pkgver-STYLE/license.txt "${pkgdir}/usr/share/licenses/ttf-c64/LICENSE" || return 1
+}
diff --git a/ttf-c64.install b/ttf-c64.install
new file mode 100644
index 000000000000..7ec1808f3412
--- /dev/null
+++ b/ttf-c64.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -fs > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}