summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2017-09-06 12:05:40 -0400
committerSolomon Choina2017-09-06 12:05:40 -0400
commit58e32b6e9319ed8c81b19c10c54d51d26726e9f5 (patch)
tree0bc9faefdb2106353c58af9da3c97ce0e02a9336
downloadaur-58e32b6e9319ed8c81b19c10c54d51d26726e9f5.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--45-caladea.conf12
-rw-r--r--90-tt-caladea.conf53
-rw-r--r--PKGBUILD39
4 files changed, 124 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32b174c0ee83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Sep 6 16:05:29 UTC 2017
+pkgbase = ttf-caladea-ib
+ pkgdesc = Caladeo is a serif font metrically compatible with Cambria.
+ pkgver = 20140817
+ pkgrel = 1
+ url = https://code.google.com/p/chromium/issues/detail?id=168879
+ arch = any
+ groups = infinality-bundle-fonts
+ license = Apache
+ depends = fontconfig
+ source = http://mirrors.ctan.org/fonts/caladea.zip
+ source = 45-caladea.conf
+ source = 90-tt-caladea.conf
+ sha1sums = a335d5e0d236cdd074ebe2964b9b8d409839513a
+ sha1sums = 90d29666e807c1f7456f4ffa86f4b6ed5b92639b
+ sha1sums = d4747515ff61405209314f9d909975eec01f56bf
+
+pkgname = ttf-caladea-ib
+
diff --git a/45-caladea.conf b/45-caladea.conf
new file mode 100644
index 000000000000..2b0f2702bfdc
--- /dev/null
+++ b/45-caladea.conf
@@ -0,0 +1,12 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+
+ <alias>
+ <family>Caladea</family>
+ <default>
+ <family>serif</family>
+ </default>
+ </alias>
+
+</fontconfig>
diff --git a/90-tt-caladea.conf b/90-tt-caladea.conf
new file mode 100644
index 000000000000..3d1681ef02d0
--- /dev/null
+++ b/90-tt-caladea.conf
@@ -0,0 +1,53 @@
+<?xml version='1.0'?>
+<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
+<fontconfig>
+
+ <match target="font">
+ <test name="force_autohint">
+ <bool>false</bool>
+ </test>
+ <test name="family">
+ <string>Caladea</string>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+ <match target="font">
+ <test name="force_autohint">
+ <bool>false</bool>
+ </test>
+ <test name="family">
+ <string>Caladea</string>
+ </test>
+ <test name="weight" compare="less">
+ <const>medium</const>
+ </test>
+ <test name="pixelsize" compare="less">
+ <double>13.5</double>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintfull</const>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+</fontconfig>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fecd5c1e1157
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: bohoomil <@zoho.com>
+
+pkgname=ttf-caladea-ib
+pkgver=20140817
+pkgrel=1
+_tarname=crosextrafonts
+depends=('fontconfig')
+pkgdesc="Caladeo is a serif font metrically compatible with Cambria."
+url="https://code.google.com/p/chromium/issues/detail?id=168879"
+arch=('any')
+groups=('infinality-bundle-fonts')
+license=('Apache')
+source=(http://mirrors.ctan.org/fonts/caladea.zip
+ 45-caladea.conf
+ 90-tt-caladea.conf)
+sha1sums=('a335d5e0d236cdd074ebe2964b9b8d409839513a'
+ '90d29666e807c1f7456f4ffa86f4b6ed5b92639b'
+ 'd4747515ff61405209314f9d909975eec01f56bf')
+
+package(){
+ cd caladea
+
+ install -D -m644 doc/LICENSE-2.0 \
+ "${pkgdir}"/usr/share/licenses/"${pkgname}"/COPYING
+
+ install -m755 -d "${pkgdir}"/usr/share/fonts/"${pkgname}"
+ install -m644 truetype/*.ttf "${pkgdir}"/usr/share/fonts/"${pkgname}"
+
+ cd "${srcdir}"
+ install -D -m644 45-caladea.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/45-caladea.conf
+ install -D -m644 90-tt-caladea.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/90-tt-caladea.conf
+
+ install -m755 -d "${pkgdir}"/etc/fonts/conf.d
+ cd "${pkgdir}"/etc/fonts/conf.d
+ ln -s ../conf.avail/45-caladea.conf .
+ ln -s ../conf.avail/90-tt-caladea.conf .
+}