summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2017-09-06 11:45:40 -0400
committerSolomon Choina2017-09-06 11:45:40 -0400
commitbfd3d0c331ac5bed3a817cf5cb80d7b48460371c (patch)
tree5f5dd5b906e7b31b69298ff17b842bc08075e2a2
downloadaur-bfd3d0c331ac5bed3a817cf5cb80d7b48460371c.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--45-carlito.conf12
-rw-r--r--90-tt-carlito.conf56
-rw-r--r--PKGBUILD37
4 files changed, 125 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5b0aa67b094
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Sep 6 15:45:32 UTC 2017
+pkgbase = ttf-carlito-ib
+ pkgdesc = Carlito is a sans-serif font metrically compatible with Calibri.
+ pkgver = 20140820
+ pkgrel = 1
+ url = https://code.google.com/p/chromium/issues/detail?id=280557
+ arch = any
+ groups = infinality-bundle-fonts
+ license = custom:OFL
+ depends = fontconfig
+ source = http://mirrors.ctan.org/fonts/carlito.zip
+ source = 45-carlito.conf
+ source = 90-tt-carlito.conf
+ sha1sums = aac0d8641b385c334593118d5e7b4691d5435ef7
+ sha1sums = ba31fb428eba83034a4d6edd31cb227d3045f2b5
+ sha1sums = 2ee9bcd6c28d0928d657d21c3a9ece5fb133c9c3
+
+pkgname = ttf-carlito-ib
+
diff --git a/45-carlito.conf b/45-carlito.conf
new file mode 100644
index 000000000000..dde534f5e9e3
--- /dev/null
+++ b/45-carlito.conf
@@ -0,0 +1,12 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+
+ <alias>
+ <family>Carlito</family>
+ <default>
+ <family>serif</family>
+ </default>
+ </alias>
+
+</fontconfig>
diff --git a/90-tt-carlito.conf b/90-tt-carlito.conf
new file mode 100644
index 000000000000..87847acab4b8
--- /dev/null
+++ b/90-tt-carlito.conf
@@ -0,0 +1,56 @@
+<?xml version='1.0'?>
+<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
+<fontconfig>
+
+ <match target="font">
+ <test name="force_autohint">
+ <bool>false</bool>
+ </test>
+ <test name="family">
+ <string>Carlito</string>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintfull</const>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+ <match target="font">
+ <test name="force_autohint">
+ <bool>false</bool>
+ </test>
+ <test name="family">
+ <string>Carlito</string>
+ </test>
+ <test name="weight" compare="less">
+ <const>medium</const>
+ </test>
+ <test name="pixelsize" compare="more">
+ <double>21.5</double>
+ </test>
+ <test name="pixelsize" compare="less">
+ <double>22.5</double>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+</fontconfig>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74aaba252597
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: bohoomil <@zoho.com>
+
+pkgname=ttf-carlito-ib
+pkgver=20140820
+pkgrel=1
+depends=('fontconfig')
+pkgdesc="Carlito is a sans-serif font metrically compatible with Calibri."
+url="https://code.google.com/p/chromium/issues/detail?id=280557"
+arch=('any')
+groups=('infinality-bundle-fonts')
+license=('custom:OFL')
+source=(http://mirrors.ctan.org/fonts/carlito.zip
+ 45-carlito.conf
+ 90-tt-carlito.conf)
+sha1sums=('aac0d8641b385c334593118d5e7b4691d5435ef7'
+ 'ba31fb428eba83034a4d6edd31cb227d3045f2b5'
+ '2ee9bcd6c28d0928d657d21c3a9ece5fb133c9c3')
+
+package(){
+ cd carlito
+
+ install -D -m644 doc/LICENSE "${pkgdir}"/usr/share/fonts/"${pkgname}"/COPYING
+
+ install -m755 -d "${pkgdir}"/usr/share/fonts/"${pkgname}"
+ install -m644 truetype/*.ttf "${pkgdir}"/usr/share/fonts/"${pkgname}"
+
+ cd "${srcdir}"
+ install -D -m644 45-carlito.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/45-carlito.conf
+ install -D -m644 90-tt-carlito.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/90-tt-carlito.conf
+
+ install -m755 -d "${pkgdir}"/etc/fonts/conf.d
+ cd "${pkgdir}"/etc/fonts/conf.d
+ ln -s ../conf.avail/45-carlito.conf .
+ ln -s ../conf.avail/90-tt-carlito.conf .
+}