summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLon Sagisawa2018-08-30 23:19:14 +0900
committerLon Sagisawa2018-08-30 23:19:14 +0900
commit5c3b8138c2ccf52ef83a0dd186a805e29711aafc (patch)
treecdf26241ff0d63b935abd84f9c2d0c40add55d3f
downloadaur-5c3b8138c2ccf52ef83a0dd186a805e29711aafc.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
-rw-r--r--ttf-cica-git.install20
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cddaed45086
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ttf-cica-git
+ pkgdesc = Composite Japanese font for coding. Mixed Ubuntu Mono, Rounded Mgen+, Nerd Fonts and Noto Emoji.
+ pkgver = v3.0.0.r4.g58ac972
+ pkgrel = 1
+ url = https://github.com/miiton/Cica
+ install = ttf-cica-git.install
+ arch = any
+ license = custom
+ makedepends = git
+ makedepends = docker
+ makedepends = docker-compose
+ depends = fontconfig
+ depends = xorg-font-utils
+ provides = ttf-cica
+ source = Cica::git+https://github.com/miiton/Cica.git
+ md5sums = SKIP
+
+pkgname = ttf-cica-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d988f80e50e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Lon Sagisawa <me(at)mlny.info>
+_reponame=Cica
+pkgname=ttf-cica-git
+pkgver=v3.0.0.r4.g58ac972
+pkgrel=1
+pkgdesc='Composite Japanese font for coding. Mixed Ubuntu Mono, Rounded Mgen+, Nerd Fonts and Noto Emoji.'
+arch=('any')
+url='https://github.com/miiton/Cica'
+license=('custom')
+depends=('fontconfig' 'xorg-font-utils')
+makedepends=('git' 'docker' 'docker-compose')
+provides=('ttf-cica')
+install=${pkgname}.install
+source=(${_reponame}::git+${url}.git)
+md5sums=('SKIP')
+
+pkgver() {
+ git -C "${_reponame}" describe --long --tags | sed "s/-/.r/;s/-/./g"
+}
+
+build() {
+ cd ${srcdir}/Cica
+ sudo docker-compose up
+ sudo docker-compose down
+}
+
+package() {
+ cd ${srcdir}/Cica
+ install -d ${pkgdir}/usr/share/fonts/TTF
+ install -m644 ./dist/*.ttf ${pkgdir}/usr/share/fonts/TTF/
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+}
diff --git a/ttf-cica-git.install b/ttf-cica-git.install
new file mode 100644
index 000000000000..f4e3ec7c3995
--- /dev/null
+++ b/ttf-cica-git.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $* \ No newline at end of file