summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorawok2017-05-18 02:09:34 -0400
committerawok2017-05-18 02:17:06 -0400
commitf0aee78936a9ca198b4e0cba8d205bd46dabd0f1 (patch)
tree153d575abcba818c3224a1af31eed86caf76337f
downloadaur-f0aee78936a9ca198b4e0cba8d205bd46dabd0f1.tar.gz
Initial commit v3.100
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD27
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfa612bb1b3b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ttf-comfortaa
+ pkgdesc = Rounded geometric sans-serif typeface from Google by Johan Aakerlund
+ pkgver = 3.100
+ pkgrel = 1
+ url = https://fonts.google.com/specimen/Comfortaa
+ arch = any
+ license = custom:SIL Open Font License v1.1
+ depends = fontconfig
+ depends = xorg-fontis-encodings
+ depends = xorg-font-utils
+ conflicts = ttf-google-fonts-git
+ conflicts = ttf-google-fonts-opinionated-git
+ source = Comfortaa-Bold-3.100.ttf::https://github.com/google/fonts/raw/4e6d978a7432514a9918b07863bb5280e7cc8815/ofl/comfortaa/Comfortaa-Bold.ttf
+ source = Comfortaa-Light-3.100.ttf::https://github.com/google/fonts/raw/4e6d978a7432514a9918b07863bb5280e7cc8815/ofl/comfortaa/Comfortaa-Light.ttf
+ source = Comfortaa-Regular-3.100.ttf::https://github.com/google/fonts/raw/4e6d978a7432514a9918b07863bb5280e7cc8815/ofl/comfortaa/Comfortaa-Regular.ttf
+ source = ttf-comfortaa-3.100-OFL.txt::https://github.com/google/fonts/raw/4e6d978a7432514a9918b07863bb5280e7cc8815/ofl/comfortaa/OFL.txt
+ sha256sums = cc4756819298e823a066213a3ebc577a4a3e9e981fe66d25f00abbce84ca1675
+ sha256sums = b92162d95548d8eef82928bc5c477def13dcdcfc1b37e3edfa4ec01957f1c9af
+ sha256sums = 96d580be232f31f051ec0573da14daf0490a0ff3e138cb616c443a14941c114f
+ sha256sums = 874ba013dd0547ea1d098cdc786297055333199d37ac1a6f8cef2577d2bc0531
+
+pkgname = ttf-comfortaa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d02dccb9f36d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Arnold G. <aurnoldg@gmail.com>
+
+pkgname=ttf-comfortaa
+pkgver=3.100
+pkgrel=1
+pkgdesc='Rounded geometric sans-serif typeface from Google by Johan Aakerlund'
+arch=('any')
+url='https://fonts.google.com/specimen/Comfortaa'
+license=('custom:SIL Open Font License v1.1')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+conflicts=('ttf-google-fonts-git' 'ttf-google-fonts-opinionated-git')
+source=("Comfortaa-Bold-${pkgver}.ttf::https://github.com/google/fonts/raw/4e6d978a7432514a9918b07863bb5280e7cc8815/ofl/comfortaa/Comfortaa-Bold.ttf"
+ "Comfortaa-Light-${pkgver}.ttf::https://github.com/google/fonts/raw/4e6d978a7432514a9918b07863bb5280e7cc8815/ofl/comfortaa/Comfortaa-Light.ttf"
+ "Comfortaa-Regular-${pkgver}.ttf::https://github.com/google/fonts/raw/4e6d978a7432514a9918b07863bb5280e7cc8815/ofl/comfortaa/Comfortaa-Regular.ttf"
+ "${pkgname}-${pkgver}-OFL.txt::https://github.com/google/fonts/raw/4e6d978a7432514a9918b07863bb5280e7cc8815/ofl/comfortaa/OFL.txt")
+sha256sums=('cc4756819298e823a066213a3ebc577a4a3e9e981fe66d25f00abbce84ca1675'
+ 'b92162d95548d8eef82928bc5c477def13dcdcfc1b37e3edfa4ec01957f1c9af'
+ '96d580be232f31f051ec0573da14daf0490a0ff3e138cb616c443a14941c114f'
+ '874ba013dd0547ea1d098cdc786297055333199d37ac1a6f8cef2577d2bc0531')
+
+package() {
+ install -dm 755 "${pkgdir}/usr/share/fonts/TTF"
+ install -m 644 Comfortaa-Bold-${pkgver}.ttf "${pkgdir}/usr/share/fonts/TTF/Comfortaa-Bold.ttf"
+ install -m 644 Comfortaa-Light-${pkgver}.ttf "${pkgdir}/usr/share/fonts/TTF/Comfortaa-Light.ttf"
+ install -m 644 Comfortaa-Regular-${pkgver}.ttf "${pkgdir}/usr/share/fonts/TTF/Comfortaa-Regular.ttf"
+ install -Dm644 ${pkgname}-${pkgver}-OFL.txt "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+}