summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAline Abler2017-02-24 10:46:42 +0100
committerAline Abler2017-02-24 10:47:54 +0100
commitcdda4bbba2b16ce764cf501a690fda364a658f4c (patch)
treec8273786969a953d7262f61defb27521d19beef3
downloadaur-cdda4bbba2b16ce764cf501a690fda364a658f4c.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD20
-rw-r--r--install13
4 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cfa72e0f371
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ttf-conkyweather
+ pkgdesc = ConkyWeather font - weather icons
+ pkgver = 20170224.3f71158
+ pkgrel = 1
+ url = https://github.com/altinukshini/conky_blue
+ install = install
+ arch = any
+ license = GPL
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = git://github.com/altinukshini/conky_blue
+ source = install
+ md5sums = SKIP
+ md5sums = b9b03309f730947d472a63b0e5ca3bb1
+
+pkgname = ttf-conkyweather
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c2cb865457b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Aline Abler <alinea@riseup.net>
+
+pkgname=ttf-conkyweather
+pkgver=20170224.3f71158
+pkgrel=1
+pkgdesc='ConkyWeather font - weather icons'
+url="https://github.com/altinukshini/conky_blue"
+license=('GPL')
+arch=('any')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+source=("git://github.com/altinukshini/conky_blue"
+ 'install')
+install=install
+
+package() {
+ install -dm755 "${pkgdir}"/usr/share/fonts/TTF
+ install -m644 conky_blue/fonts/conkyweather.ttf "${pkgdir}"/usr/share/fonts/TTF
+}
+md5sums=('SKIP'
+ 'b9b03309f730947d472a63b0e5ca3bb1')
diff --git a/install b/install
new file mode 100644
index 000000000000..0fc2f60814bc
--- /dev/null
+++ b/install
@@ -0,0 +1,13 @@
+post_install() {
+ fc-cache -s -f > /dev/null
+ mkfontscale usr/share/fonts/TTF
+ mkfontdir usr/share/fonts/TTF
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}