summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikhail f. Shiryaev2020-05-27 21:52:46 +0200
committerMikhail f. Shiryaev2020-05-27 21:53:01 +0200
commit3e8fd62b197c903b10a818dfd4d49c3d29ceb543 (patch)
tree48a9d22daa64e6dfe64ddffeba4e4386565bf282
parent52c80eae0310a1bd9ed40aa235d0f4c4ee4d39a2 (diff)
downloadaur-3e8fd62b197c903b10a818dfd4d49c3d29ceb543.tar.gz
Fix building, update to version 2
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e842e6d60775..37742b2b5d34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = ttf-consolas-ligaturized
- pkgdesc = Standard Consolas font with FiraCode ligatures.
- pkgver = 1.0.0
+ pkgdesc = Standard Consolas font with FiraCode ligatures. Versions 1 and 2 are included
+ pkgver = 2
pkgrel = 1
+ url = https://github.com/somq/consolas-ligaturized
arch = any
license = CUSTOM
depends = fontconfig
depends = xorg-font-utils
depends = xorg-mkfontdir
- source = https://github.com/somq/consolas-ligaturized/archive/1.0.0.tar.gz
- sha256sums = 92bab70e3881b45260be620fbffaf8acb1f9017f108ff06353b1e195649eef7d
+ source = https://github.com/somq/consolas-ligaturized/archive/2.tar.gz
+ sha256sums = 968eaab67578feae22f09e894e4b36f2ef0f13a777ff9f43d11e10bda4b640e7
pkgname = ttf-consolas-ligaturized
diff --git a/PKGBUILD b/PKGBUILD
index 08c933fc8abf..a7ed762c34f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
fontname=consolas-ligaturized
pkgname="ttf-${fontname}"
-pkgver=1.0.0
+pkgver=2
pkgrel=1
-pkgdesc='Standard Consolas font with FiraCode ligatures.'
+pkgdesc='Standard Consolas font with FiraCode ligatures. Versions 1 and 2 are included'
arch=(any)
license=(CUSTOM)
+url="https://github.com/somq/${fontname}"
depends=(fontconfig xorg-font-utils xorg-mkfontdir)
-source=("https://github.com/somq/${fontname}/archive/${pkgver}.tar.gz")
-sha256sums=(92bab70e3881b45260be620fbffaf8acb1f9017f108ff06353b1e195649eef7d)
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=(968eaab67578feae22f09e894e4b36f2ef0f13a777ff9f43d11e10bda4b640e7)
package() {
mkdir -p "$pkgdir/usr/share/fonts/${fontname}"
mkdir -p "$pkgdir/usr/share/licenses/${pkgname}"
cp "${srcdir}/${fontname}-${pkgver}/"*.ttf "$pkgdir/usr/share/fonts/${fontname}"
- cp "${srcdir}/${fontname}-${pkgver}/LICENSE" "$pkgdir/usr/share/licenses/${pkgname}"
+ cp "${srcdir}/${fontname}-${pkgver}/LICENSE" "$pkgdir/usr/share/licenses/${pkgname}"
}