summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoredward-p2019-03-07 12:41:10 +0800
committeredward-p2019-03-07 12:41:10 +0800
commitf1ef749deec2eca521e235ac33b71754f606dae2 (patch)
tree7da1291940ef6739b14f35f9fc99b7366812a459
parent28cedd638617413e8845f9a25ba2646037847ea8 (diff)
downloadaur-f1ef749deec2eca521e235ac33b71754f606dae2.tar.gz
add pkgver
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c36caa0eb77..e5675568ef7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ttf-consolas-with-yahei-powerline-git
pkgdesc = Consolas-with-Yahei with powerline patched with nerd-fonts)
- pkgver = 0.1.1
- pkgrel = 0
+ pkgver = r2.28cedd6
+ pkgrel = 1
url = https://github.com/crvdgc/Consolas-with-Yahei
install = ttf-consolas-with-yahei-powerline-git.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index d5dc4bff3ee5..bb033fe66f4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: edward-p <micro.fedora@gmail.com>
pkgname=ttf-consolas-with-yahei-powerline-git
-pkgver='0.1.1'
-pkgrel=0
+pkgver=r2.28cedd6
+pkgrel=1
pkgdesc="Consolas-with-Yahei with powerline patched with nerd-fonts)"
arch=(any)
url=https://github.com/crvdgc/Consolas-with-Yahei
@@ -11,6 +11,14 @@ makedepends=(tar)
fontname='consolas-with-yahei'
install=$pkgname.install
+pkgver() {
+ cd "$srcdir/$_pkgbase"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
prepare(){
git clone --depth=1 https://github.com/crvdgc/Consolas-with-Yahei.git
}