summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJinho Jeong2015-09-16 21:34:07 +0900
committerJinho Jeong2015-09-16 21:34:07 +0900
commit43490906b7a12eb7b3582abbcedc00a0fb9367c3 (patch)
tree1b61634a0762458f86540ee400eb4747251241c2
downloadaur-43490906b7a12eb7b3582abbcedc00a0fb9367c3.tar.gz
initial release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
-rw-r--r--ttf.install18
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e370e076b07
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-d2coding
+ pkgdesc = D2Coding Fixed Width TrueType fonts
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://dev.naver.com/projects/d2coding
+ install = ttf.install
+ arch = any
+ license = OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ provides = ttf-font
+ source = http://dev.naver.com/frs/download.php/11300/D2Coding-Ver1.0-TTC-20150911.zip
+ md5sums = 5fc42a9b9396395c6bd312ca818f038c
+
+pkgname = ttf-d2coding
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ecb76e09111
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor : Jinho Jeong <jjinho0203@gmail.com>
+
+pkgname=ttf-d2coding
+pkgver=1.0
+pkgrel=1
+pkgdesc="D2Coding Fixed Width TrueType fonts"
+arch=('any')
+url="http://dev.naver.com/projects/d2coding"
+license=('OFL')
+depends=('fontconfig' 'xorg-font-utils')
+provides=('ttf-font')
+install=ttf.install
+source=('http://dev.naver.com/frs/download.php/11300/D2Coding-Ver1.0-TTC-20150911.zip')
+md5sums=('5fc42a9b9396395c6bd312ca818f038c')
+
+package() {
+ install -dm 755 ${pkgdir}/usr/share/fonts/TTF
+
+ install -m 644 -T ${srcdir}/D2Coding.ttc ${pkgdir}/usr/share/fonts/TTF/D2Coding.ttc
+}
+
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..774ea5acd9c0
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,18 @@
+
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+$op $*