summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Turner2017-01-04 12:31:44 -0500
committerWilliam Turner2017-01-04 12:31:44 -0500
commit341801643d92fe3382543a3b151efbd876e2f652 (patch)
tree8980fcdff431eac015c47b45e2a2877728c3ff94
downloadaur-341801643d92fe3382543a3b151efbd876e2f652.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
-rw-r--r--fonts.install11
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42ebf67c5e06
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ttf-dejavu-sans-code-git
+ pkgdesc = Monospaced font with programming ligatures based on DejaVu Sans Mono
+ pkgver = 1.2.r0.b244a9c
+ pkgrel = 1
+ url = https://github.com/SSNikolaevich/DejaVuSansCode
+ install = fonts.install
+ arch = any
+ license = custom
+ makedepends = git
+ makedepends = fontforge
+ makedepends = perl-font-ttf
+ depends = fontconfig
+ depends = xorg-font-utils
+ provides = ttf-dejavu-sans-code
+ conflicts = ttf-dejavu-sans-code
+ source = git+https://github.com/SSNikolaevich/DejaVuSansCode.git
+ md5sums = SKIP
+
+pkgname = ttf-dejavu-sans-code-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..912157537169
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: William Turner <willtur.will@gmail.com>
+pkgname=ttf-dejavu-sans-code-git
+pkgver=1.2.r0.b244a9c
+pkgrel=1
+pkgdesc='Monospaced font with programming ligatures based on DejaVu Sans Mono'
+arch=('any')
+url='https://github.com/SSNikolaevich/DejaVuSansCode'
+license=('custom')
+groups=()
+depends=('fontconfig' 'xorg-font-utils')
+makedepends=('git' 'fontforge' 'perl-font-ttf')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=fonts.install
+source=('git+https://github.com/SSNikolaevich/DejaVuSansCode.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/DejaVuSansCode"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/DejaVuSansCode"
+ make full-ttf
+}
+
+package() {
+ cd "$srcdir/DejaVuSansCode"
+ install -d ${pkgdir}/usr/share/fonts/TTF/
+ install -m644 build/*.ttf ${pkgdir}/usr/share/fonts/TTF/
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/fonts.install b/fonts.install
new file mode 100644
index 000000000000..ac6cb5b6f4ac
--- /dev/null
+++ b/fonts.install
@@ -0,0 +1,11 @@
+post_install() {
+ fc-cache -s
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}