summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics@felics-tablet2018-02-12 21:27:39 +0100
committerfelics@felics-tablet2018-02-12 21:27:39 +0100
commit6ba4f579b00738b2bfac3d7c746c5ea238057655 (patch)
tree97b400e5c8086344b98267523b14f6c60ebc7e05
downloadaur-6ba4f579b00738b2bfac3d7c746c5ea238057655.tar.gz
Initial commit.
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD59
-rw-r--r--dniscript.install14
-rw-r--r--license-dummy.txt5
4 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..509cf0d85e20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = ttf-dni
+ pkgdesc = TrueType D'ni font (from the Myst game series). Contains a normal version, a version with character mapping according to new standard, and an angular (non-round) version.
+ pkgver = 2.2
+ pkgrel = 1
+ url = http://linguists.riedl.org/old/sebastian/
+ install = dniscript.install
+ arch = any
+ license = custom
+ makedepends = fontconfig
+ makedepends = unzip
+ makedepends = xorg-mkfontscale
+ makedepends = xorg-mkfontdir
+ makedepends = xorg-xset
+ provides = ttf-dniscript=2.2
+ source = http://linguists.riedl.org/old/sebastian/dniscrpt22.zip
+ source = website.html::http://linguists.riedl.org/old/sebastian/
+ source = license-dummy.txt
+ source = dniscript.install
+ sha256sums = 11e684041c2a8baecb4868442ecb6036c42f97d5bd96785f562ca1855697c466
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = ttf-dni
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f4eff367191
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: dreieck
+
+_pkgname=ttf-dni
+pkgname="${_pkgname}"
+pkgver=2.2
+_dlver="$(echo ${pkgver} | tr -d '.')"
+pkgrel=1
+pkgdesc="TrueType D'ni font (from the Myst game series). Contains a normal version, a version with character mapping according to new standard, and an angular (non-round) version."
+arch=('any')
+url="http://linguists.riedl.org/old/sebastian/"
+license=('custom')
+
+depends=(
+)
+
+makedepends=(
+ "fontconfig"
+ "unzip"
+ "xorg-mkfontscale"
+ "xorg-mkfontdir"
+ "xorg-xset"
+)
+
+provides=("ttf-dniscript=${pkgver}")
+
+install='dniscript.install'
+
+source=(
+ "http://linguists.riedl.org/old/sebastian/dniscrpt${_dlver}.zip"
+ "website.html::${url}"
+ "license-dummy.txt"
+ "${install}"
+)
+
+sha256sums=(
+ "11e684041c2a8baecb4868442ecb6036c42f97d5bd96785f562ca1855697c466"
+ "SKIP"
+ "SKIP"
+ "SKIP"
+)
+
+prepare() {
+ cd "${srcdir}"
+ echo "${url}" > "${srcdir}/website.url"
+}
+
+package() {
+ cd "${srcdir}"
+
+ install -D -v -m644 "D'NI_ANG.TTF" "${pkgdir}/usr/share/fonts/dniscript/dni_ang.ttf"
+ install -D -v -m644 "D'NI_SCR.TTF" "${pkgdir}/usr/share/fonts/dniscript/dni_scr.ttf"
+ install -D -v -m644 "D'NI_SLM.TTF" "${pkgdir}/usr/share/fonts/dniscript/dni_slm.ttf"
+
+ install -D -v -m644 license-dummy.txt "${pkgdir}/usr/share/licenses/${pkgname}/copying.txt"
+ install -D -v -m644 README.HTM "${pkgdir}/usr/share/doc/${_pkgname}/readme.html"
+ install -D -v -m644 WHATSNEW.TXT "${pkgdir}/usr/share/doc/${_pkgname}/whatsnew.txt"
+ install -D -v -m644 website.html "${pkgdir}/usr/share/doc/${_pkgname}/website.html"
+ install -D -v -m644 website.url "${pkgdir}/usr/share/doc/${_pkgname}/website.url"
+}
diff --git a/dniscript.install b/dniscript.install
new file mode 100644
index 000000000000..1ae8213431da
--- /dev/null
+++ b/dniscript.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo -n "Updating font cache ... "
+ fc-cache -s
+ mkfontscale /usr/share/fonts/dniscript
+ mkfontdir /usr/share/fonts/dniscript
+}
+
+post_upgrade() {
+ post_install "$@"
+}
+
+post_remove() {
+ post_install "$@"
+}
diff --git a/license-dummy.txt b/license-dummy.txt
new file mode 100644
index 000000000000..647eeacbdd78
--- /dev/null
+++ b/license-dummy.txt
@@ -0,0 +1,5 @@
+We do not know the license.
+
+Assume all rights by the author (Guild Master Sebastian, <sebOchs (at) gmx (dog) de>).
+
+Upstream URL: http://linguists.riedl.org/old/sebastian/