summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Bartell2015-06-08 10:39:34 -0500
committerSean Bartell2015-06-08 10:39:34 -0500
commit11450f4866a162a81e91835fbea7f6c4e4a8f82e (patch)
tree258d5b06d9b76ef71359dd3bb7ee0362a2b74653
downloadaur-11450f4866a162a81e91835fbea7f6c4e4a8f82e.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--LICENCE45
-rw-r--r--PKGBUILD21
-rw-r--r--ttf-dpcustommono2.install15
4 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b67bf264d0e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ttf-dpcustommono2
+ pkgdesc = PGDP font with exaggerated clarity to aid proofreading
+ pkgver = 2.01
+ pkgrel = 1
+ url = http://www.pgdp.net/wiki/DPCustomMono2
+ install = ttf-dpcustommono2.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = LICENCE
+ source = http://www.pgdp.net/c/faq/DPCustomMono2.ttf
+ md5sums = f5df9c45b5f3b8c8b6d959270b90b3ba
+ md5sums = 59cc971a9f549d470de0fecc707f3e9c
+ sha256sums = 38dcea7efe04c7c17ed2e0ab013e3eff7e7340fe7cb1e31491359e0b509373c3
+ sha256sums = fa065d94451666170037322de2a1a66a2a493961d8021e23cb5bdb0f909041f0
+
+pkgname = ttf-dpcustommono2
+
diff --git a/LICENCE b/LICENCE
new file mode 100644
index 000000000000..ee956469a80a
--- /dev/null
+++ b/LICENCE
@@ -0,0 +1,45 @@
+Copyright (c) 2003 by Bitstream, Inc.
+
+All Rights Reserved.
+
+Bitstream Vera is a trademark of Bitstream, Inc.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of
+the fonts accompanying this license ("Fonts") and associated documentation
+files (the "Font Software"), to reproduce and distribute the Font Software,
+including without limitation the rights to use, copy, merge, publish,
+distribute, and/or sell copies of the Font Software, and to permit persons to
+whom the Font Software is furnished to do so, subject to the following
+conditions:
+
+The above copyright and trademark notices and this permission notice shall be
+included in all copies of one or more of the Font Software typefaces.
+
+The Font Software may be modified, altered, or added to, and in particular the
+designs of glyphs or characters in the Fonts may be modified and additional
+glyphs or characters may be added to the Fonts, only if the fonts are renamed
+to names not containing either the words "Bitstream" or the word "Vera".
+
+This License becomes null and void to the extent applicable to Fonts or Font
+Software that has been modified and is distributed under the "Bitstream Vera"
+names.
+
+The Font Software may be sold as part of a larger software package but no copy
+of one or more of the Font Software typefaces may be sold by itself.
+
+THE FONT SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO ANY WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF COPYRIGHT, PATENT,
+TRADEMARK, OR OTHER RIGHT. IN NO EVENT SHALL BITSTREAM OR THE GNOME FOUNDATION
+BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, INCLUDING ANY GENERAL,
+SPECIAL, INDIRECT, INCIDENTAL, OR CONSEQUENTIAL DAMAGES, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF THE USE OR INABILITY TO
+USE THE FONT SOFTWARE OR FROM OTHER DEALINGS IN THE FONT SOFTWARE.
+
+Except as contained in this notice, the names of Gnome, the Gnome Foundation,
+and Bitstream Inc., shall not be used in advertising or otherwise to promote
+the sale, use or other dealings in this Font Software without prior written
+authorization from the Gnome Foundation or Bitstream Inc., respectively. For
+further information, contact: fonts at gnome dot org.
+
+Copyright (c) 2003 by Distributed Proofreaders. All Rights Reserved.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f7adfe5934b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Sean Bartell <yotann@yotann.org>
+
+pkgname=ttf-dpcustommono2
+pkgver=2.01
+pkgrel=1
+pkgdesc="PGDP font with exaggerated clarity to aid proofreading"
+arch=(any)
+depends=(fontconfig xorg-font-utils)
+url="http://www.pgdp.net/wiki/DPCustomMono2"
+source=(LICENCE http://www.pgdp.net/c/faq/DPCustomMono2.ttf)
+install=$pkgname.install
+license=('custom')
+md5sums=('f5df9c45b5f3b8c8b6d959270b90b3ba'
+ '59cc971a9f549d470de0fecc707f3e9c')
+sha256sums=('38dcea7efe04c7c17ed2e0ab013e3eff7e7340fe7cb1e31491359e0b509373c3'
+ 'fa065d94451666170037322de2a1a66a2a493961d8021e23cb5bdb0f909041f0')
+
+package() {
+ install -D -m644 "$srcdir/DPCustomMono2.ttf" "$pkgdir/usr/share/fonts/TTF/DPCustomMono2.ttf"
+ install -D -m644 "$srcdir/LICENCE" "$pkgdir/usr/share/licenses/$pkgname/LICENCE"
+}
diff --git a/ttf-dpcustommono2.install b/ttf-dpcustommono2.install
new file mode 100644
index 000000000000..c2f11b1d7317
--- /dev/null
+++ b/ttf-dpcustommono2.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache >/dev/null -f
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo done
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}