summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDevin Christensen2015-06-27 20:27:46 -0600
committerDevin Christensen2015-06-27 20:27:46 -0600
commitc205fbf0096bd4a7a51773f333a2811fb93e912b (patch)
tree9af2a952adc302cb47ceb3bf5d6d0290802d5386
downloadaur-c205fbf0096bd4a7a51773f333a2811fb93e912b.tar.gz
Create package
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
-rw-r--r--ttf-droid-sans-mono-slashed-powerline-git.install15
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f63271cbec31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ttf-droid-sans-mono-slashed-powerline-git
+ pkgdesc = Droid Sans Mono for Powerline (Slashed Zero)
+ pkgver = r78.97dc451
+ pkgrel = 1
+ url = https://github.com/powerline/fonts
+ install = ttf-droid-sans-mono-slashed-powerline-git.install
+ arch = any
+ license = custom:Apache License, Version 2.0
+ makedepends = git
+ depends = fontconfig
+ depends = xorg-font-utils
+ conflicts = powerline-fonts
+ conflicts = powerline-fonts-git
+ source = git://github.com/powerline/fonts.git
+ md5sums = SKIP
+
+pkgname = ttf-droid-sans-mono-slashed-powerline-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b3b81120d60b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/fonts/
+/pkg/
+/src/
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..834aff6f62e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Devin Christensen <quixoten at gmail dot com>
+pkgname=ttf-droid-sans-mono-slashed-powerline-git
+pkgver=r78.97dc451
+pkgrel=1
+pkgdesc="Droid Sans Mono for Powerline (Slashed Zero)"
+arch=('any')
+url=('https://github.com/powerline/fonts')
+license=('custom:Apache License, Version 2.0')
+depends=(fontconfig xorg-font-utils )
+makedepends=('git')
+conflicts=(powerline-fonts powerline-fonts-git)
+install=$pkgname.install
+source=('git://github.com/powerline/fonts.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd fonts
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $srcdir/fonts/DroidSansMonoSlashed
+ find . -iname '*.ttf' -execdir install -Dm644 {} $pkgdir/usr/share/fonts/TTF/{} \;
+ install -Dm644 LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/ttf-droid-sans-mono-slashed-powerline-git.install b/ttf-droid-sans-mono-slashed-powerline-git.install
new file mode 100644
index 000000000000..f8ecdd439d8a
--- /dev/null
+++ b/ttf-droid-sans-mono-slashed-powerline-git.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ mkfontscale /usr/share/fonts/OTF > /dev/null 2>&1
+ mkfontdir /usr/share/fonts/OTF > /dev/null 2>&1
+ fc-cache -s >/dev/null
+ echo "done"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}