summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Schönherr2017-01-29 14:13:01 +0100
committerMoritz Schönherr2017-01-29 14:13:01 +0100
commitee41ad97c063651296e2aedf7764445dd3393e48 (patch)
tree5155d9a3ba7766b568e0d3616294518f77952436
downloadaur-ee41ad97c063651296e2aedf7764445dd3393e48.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE3
-rw-r--r--PKGBUILD21
-rw-r--r--ttf.install16
4 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a304dc8c55f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-fate-core
+ pkgdesc = The ttf font used in the Fate Core Rulebook
+ pkgver = 1
+ pkgrel = 1
+ url = http://faterpg.com
+ install = ttf.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = http://www.faterpg.com/wp-content/uploads/2013/06/Fate-Core-Font.ttf_.zip
+ md5sums = c910b1af331ab2a785d24cd51d0a0559
+
+pkgname = ttf-fate-core
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..02782f4fded1
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,3 @@
+To make use of it, just give us credit
+
+"The Fate Core font is © Evil Hat Productions, LLC and is used with permission. The Four Actions icons were designed by Jeremy Keller."
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0637b313f27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Moritz Schönherr <moritz.schoenherr@gmail.com>
+pkgname=ttf-fate-core
+pkgver=1
+pkgrel=1
+pkgdesc="The ttf font used in the Fate Core Rulebook"
+arch=('any')
+license=('custom')
+url="http://faterpg.com"
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+install=ttf.install
+source=("http://www.faterpg.com/wp-content/uploads/2013/06/Fate-Core-Font.ttf_.zip")
+
+md5sums=('c910b1af331ab2a785d24cd51d0a0559')
+
+package() {
+ cd $srcdir
+ mv 'Fate Core Font.ttf' fate-core.ttf
+ install -d $pkgdir/usr/share/fonts/TTF/
+ install -m644 *.ttf $pkgdir/usr/share/fonts/TTF/ || return 1
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..24b98c5f9b15
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo " ...done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+