summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph J. Thompson2015-08-12 01:15:54 +0200
committerChristoph J. Thompson2015-08-12 01:15:54 +0200
commit640c059af24ad8525dcb59552a4e60539fb93ba5 (patch)
treef3862b06cda96dfa238bf6628ac1e20f549ba819
downloadaur-640c059af24ad8525dcb59552a4e60539fb93ba5.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
-rw-r--r--ttf-fixedsys-excelsior-linux.install13
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2ef6013b236
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-fixedsys-excelsior-linux
+ pkgdesc = fixedsys font for linux, use only at 12pt
+ pkgver = 3.0.1
+ pkgrel = 2
+ url = https://bugs.launchpad.net/ubuntu/+bug/200671
+ install = ttf-fixedsys-excelsior-linux.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = http://launchpadlibrarian.net/26228254/FSEX301-L2.ttf
+ sha256sums = e07f8a9edd4b633dba6cc08f12a8d9cbf4d10b177fea64cdb5741c60dd27dfc7
+
+pkgname = ttf-fixedsys-excelsior-linux
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df47b4ac7792
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Christoph J. Thompson <thompsonc@protonmail.ch>
+
+pkgname=ttf-fixedsys-excelsior-linux
+pkgver=3.0.1
+pkgrel=2
+pkgdesc="fixedsys font for linux, use only at 12pt"
+arch=('any')
+url="https://bugs.launchpad.net/ubuntu/+bug/200671"
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+license=('custom')
+install="ttf-fixedsys-excelsior-linux.install"
+source=(http://launchpadlibrarian.net/26228254/FSEX301-L2.ttf)
+sha256sums=(e07f8a9edd4b633dba6cc08f12a8d9cbf4d10b177fea64cdb5741c60dd27dfc7)
+
+package() {
+ install -m 0755 -d "${pkgdir}/usr/share/fonts/TTF"
+ install -m 0644 FSEX301-L2.ttf "${pkgdir}/usr/share/fonts/TTF"
+}
+
diff --git a/ttf-fixedsys-excelsior-linux.install b/ttf-fixedsys-excelsior-linux.install
new file mode 100644
index 000000000000..18666d2a3d6c
--- /dev/null
+++ b/ttf-fixedsys-excelsior-linux.install
@@ -0,0 +1,13 @@
+post_install() {
+ fc-cache -fs
+ mkfontscale usr/share/fonts/TTF
+ mkfontdir usr/share/fonts/TTF
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}