summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeposite Pirate2018-08-28 16:40:25 +0200
committerDeposite Pirate2018-08-28 16:40:25 +0200
commit783b5482aff13630f69039f061b891aaa9541b8f (patch)
treec0fb2b599a8c0df2217548c3eb3f18bd2d30c46f
parent640c059af24ad8525dcb59552a4e60539fb93ba5 (diff)
downloadaur-783b5482aff13630f69039f061b891aaa9541b8f.tar.gz
* Update to the newer version with ligatures
* Small updates modified: .SRCINFO modified: PKGBUILD
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2ef6013b236..b377ae63bbc2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = ttf-fixedsys-excelsior-linux
pkgdesc = fixedsys font for linux, use only at 12pt
- pkgver = 3.0.1
- pkgrel = 2
- url = https://bugs.launchpad.net/ubuntu/+bug/200671
+ pkgver = 3.02.9
+ pkgrel = 1
+ url = https://github.com/kika/fixedsys
install = ttf-fixedsys-excelsior-linux.install
arch = any
license = custom
depends = fontconfig
depends = xorg-fonts-encodings
depends = xorg-font-utils
- source = http://launchpadlibrarian.net/26228254/FSEX301-L2.ttf
- sha256sums = e07f8a9edd4b633dba6cc08f12a8d9cbf4d10b177fea64cdb5741c60dd27dfc7
+ source = https://github.com/kika/fixedsys/releases/download/v3.02.9/FSEX302.ttf
+ source = https://github.com/kika/fixedsys/releases/download/v3.02.9/FSEX302-alt.ttf
+ sha256sums = b3f8e1da97b722a42477ee9a72f953eb2bc7c2195df5e2b6b7d4781dd3f8b2cc
+ sha256sums = e4abb547b387d4676892f2db7c4a19d5cda0a91680ccc52331b2b49456e307da
pkgname = ttf-fixedsys-excelsior-linux
diff --git a/PKGBUILD b/PKGBUILD
index df47b4ac7792..75e9921b83b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
-# Maintainer: Christoph J. Thompson <thompsonc@protonmail.ch>
+# Maintainer: Christoph J. Thompson <thompsonc at protonmail dot ch>
pkgname=ttf-fixedsys-excelsior-linux
-pkgver=3.0.1
-pkgrel=2
+pkgver=3.02.9
+pkgrel=1
pkgdesc="fixedsys font for linux, use only at 12pt"
arch=('any')
-url="https://bugs.launchpad.net/ubuntu/+bug/200671"
+url="https://github.com/kika/fixedsys"
depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
license=('custom')
install="ttf-fixedsys-excelsior-linux.install"
-source=(http://launchpadlibrarian.net/26228254/FSEX301-L2.ttf)
-sha256sums=(e07f8a9edd4b633dba6cc08f12a8d9cbf4d10b177fea64cdb5741c60dd27dfc7)
+source=("${url}/releases/download/v${pkgver}/FSEX302.ttf"
+ "${url}/releases/download/v${pkgver}/FSEX302-alt.ttf")
+sha256sums=('b3f8e1da97b722a42477ee9a72f953eb2bc7c2195df5e2b6b7d4781dd3f8b2cc'
+ 'e4abb547b387d4676892f2db7c4a19d5cda0a91680ccc52331b2b49456e307da')
package() {
- install -m 0755 -d "${pkgdir}/usr/share/fonts/TTF"
- install -m 0644 FSEX301-L2.ttf "${pkgdir}/usr/share/fonts/TTF"
+ install -dm755 "${pkgdir}/usr/share/fonts/TTF"
+ install -m644 FSEX*.ttf "${pkgdir}/usr/share/fonts/TTF"
}
-