summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2019-04-03 06:38:37 +0000
committerAntonio Rojas2019-04-03 06:38:37 +0000
commit7b5b7924e769e5b5205db5f217322b0fd8455e0e (patch)
treef229eeaed63c123e5bc1df9c0869e774bcc2d4ed
downloadaur-7b5b7924e769e5b5205db5f217322b0fd8455e0e.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD53
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1be3fe7b5dc0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ttf-freebanglafont
+ pkgdesc = Bengali fonts
+ pkgver = 20130212
+ pkgrel = 3
+ url = http://www.ekushey.org/
+ arch = any
+ license = GPL
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ depends = fontconfig
+ source = https://sources.archlinux.org/other/packages/ttf-freebanglafont/ttf-freebanglafont-20130212-2.src.tar.gz
+ sha256sums = 19a85c6b76e1b3bff3864485a40724fad7c1224a5e20960be08e31659b91e502
+
+pkgname = ttf-freebanglafont
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5025024cc53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
+# Contributor: Firmicus <francois.archlinux.org>
+
+pkgname=ttf-freebanglafont
+pkgver=20130212
+pkgrel=3
+pkgdesc='Bengali fonts'
+url='http://www.ekushey.org/'
+license=('GPL')
+arch=('any')
+depends=('xorg-fonts-encodings' 'xorg-font-utils' 'fontconfig')
+
+package() {
+ cd "${srcdir}/ttf-freebanglafont/"
+ for i in *.ttf; do
+ install -Dm644 "${i}" "${pkgdir}/usr/share/fonts/TTF/${i}.ttf"
+ done
+}
+
+_fonts=('solaimanlipi'
+ 'rupali'
+ 'ekushey_lohit'
+ 'ekushey_sharifa'
+ 'ekushey-punarbhaba'
+ 'ekushey_sumit'
+ 'ekushey-durga'
+ 'ekushey_Saraswatii'
+ 'ekushey_puja'
+ 'ekushey_azad'
+ 'ekushey_godhuli'
+ 'ekushey_mohua'
+ '16-december'
+ 'amar-bangla'
+ 'amar-desh'
+ 'bangla-kolom'
+ 'buriganga'
+ 'ekushey-bangla'
+ 'ekushey-kolom'
+ 'ekushey-sumon'
+ 'ghorautra'
+ 'lal-sabuj'
+ 'lal-sabuj-normal'
+ 'lal-salu'
+ 'preview-sornaly'
+ 'preview-mukto'
+ 'preview-shimanto'
+ 'preview-ananta')
+
+#source=($(for i in ${_fonts[@]}; do curl -s http://ekushey.org/?page/$i | sed -e 's/"/\n/g' | grep 'http:.*.ttf'; done))
+
+source=(https://sources.archlinux.org/other/packages/${pkgname}/ttf-freebanglafont-20130212-2.src.tar.gz)
+sha256sums=('19a85c6b76e1b3bff3864485a40724fad7c1224a5e20960be08e31659b91e502')