summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuiz Silveira2018-01-11 12:45:46 -0200
committerLuiz Silveira2018-01-11 12:45:46 -0200
commit0e2ecde51cfaffeb5770c8c04cad749e03da0bcb (patch)
tree4d98de6cb5d39717c7ff7525f0c15951afe921db
downloadaur-0e2ecde51cfaffeb5770c8c04cad749e03da0bcb.tar.gz
migrated from AUR 3 archive
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE5
-rw-r--r--PKGBUILD27
-rw-r--r--ttf.install17
4 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8de5f5eb18e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-funfonts
+ pkgdesc = 76 selected TTF fonts from 6760 font packages
+ pkgver = 2
+ pkgrel = 1
+ url = http://thelinuxbox.org/
+ install = ttf.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://thelinuxbox.org/downloads/fonts/funfonts.tar.gz
+ source = LICENSE
+ md5sums = 3dd9c79d77e58cdb532cc6c21e7914d5
+ md5sums = d30e0838c9a9f2a6148bda33b28ad6a6
+
+pkgname = ttf-funfonts
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..c328b7e14b5a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,5 @@
+Fun fonts are intended for creating eye-catching documents and graphics.
+These fonts have been collected from various places on the web so it
+incorporates a rather eccentric collection of fonts and licenses.
+
+I recommend not trying to (re)sell the included fonts.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dce3c9fe542b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# (new) AUR 4 Maintainer: zertyz@gmail.com
+# (old) AUR 3 Maintainer: TDY <tdy@archlinux.info>
+# Contributor: Ronny Steiner <post@sirsteiner.de>
+# Contributor: Darío Andrés Rodríguez <darzephyr@gmail.com>
+
+pkgname=ttf-funfonts
+pkgver=2
+pkgrel=1
+pkgdesc="76 selected TTF fonts from 6760 font packages"
+arch=('any')
+url="http://thelinuxbox.org/"
+license=('custom')
+depends=('fontconfig' 'xorg-font-utils')
+install=ttf.install
+source=(http://thelinuxbox.org/downloads/fonts/${pkgname#*-}.tar.gz
+ LICENSE)
+md5sums=('3dd9c79d77e58cdb532cc6c21e7914d5'
+ 'd30e0838c9a9f2a6148bda33b28ad6a6')
+
+package() {
+ cd "$srcdir/${pkgname#*-}"
+ install -dm755 "$pkgdir/usr/share/fonts/TTF/"
+ install -m644 *.ttf "$pkgdir/usr/share/fonts/TTF/"
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..7370041e234b
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,17 @@
+post_install() {
+ echo -n "==> Rebuilding font cache... "
+ fc-cache -f &> /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+# vim:set ts=2 sw=2 et: