summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYang Niao2022-02-26 02:56:41 +0900
committerYang Niao2022-02-26 02:56:41 +0900
commit2d861e2aac2a855beab792af6129f19864d9e104 (patch)
treede1858e3a9164cb3bde22bf74f77ca4c557b7b39
downloadaur-2d861e2aac2a855beab792af6129f19864d9e104.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
-rw-r--r--ttf-genjyuu-gothic.install13
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73f430c079b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-genjyuu-gothic
+ pkgdesc = Japanese TrueType font processed in a round gothic style based on Source Han Sans
+ pkgver = 20150607
+ pkgrel = 1
+ url = http://jikasei.me/font/genjyuu/
+ install = ttf-genjyuu-gothic.install
+ arch = any
+ license = custom:SIL Open Font License 1.1
+ source = https://ja.osdn.net/downloads/users/8/8636/genjyuugothic-20150607.7z
+ source = https://ja.osdn.net/downloads/users/8/8638/genjyuugothic-x-20150607.7z
+ source = https://ja.osdn.net/downloads/users/8/8635/genjyuugothic-l-20150607.7z
+ sha256sums = 1997876351985ac9e2ea7a7a809c91e3fdaef878ece5b830f2512c882c3e49db
+ sha256sums = 553967bdf0066069e4f687c81ded9c7d7bc1abcbd32d9177efc2bf85e7f8037a
+ sha256sums = 698007a5783e97e821b929d0e57f74446a86dece5032fe576897356586f76cbb
+
+pkgname = ttf-genjyuu-gothic
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b86dc8eed3a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: yangniao23 <yangniao23 (at) gmail (dot) com>
+
+pkgname=ttf-genjyuu-gothic
+pkgver=20150607
+pkgrel=1
+pkgdesc="Japanese TrueType font processed in a round gothic style based on Source Han Sans"
+url="http://jikasei.me/font/genjyuu/"
+license=('custom:SIL Open Font License 1.1')
+arch=('any')
+install=$pkgname.install
+source=("https://ja.osdn.net/downloads/users/8/8636/genjyuugothic-${pkgver}.7z"
+ "https://ja.osdn.net/downloads/users/8/8638/genjyuugothic-x-${pkgver}.7z"
+ "https://ja.osdn.net/downloads/users/8/8635/genjyuugothic-l-${pkgver}.7z"
+)
+sha256sums=(
+ '1997876351985ac9e2ea7a7a809c91e3fdaef878ece5b830f2512c882c3e49db'
+ '553967bdf0066069e4f687c81ded9c7d7bc1abcbd32d9177efc2bf85e7f8037a'
+ '698007a5783e97e821b929d0e57f74446a86dece5032fe576897356586f76cbb'
+)
+
+package() {
+ cd "${srcdir}"
+ install -dm755 "${pkgdir}"/usr/share/fonts/TTF
+ install -m644 *.ttf "${pkgdir}"/usr/share/fonts/TTF/
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dm644 SIL_Open_Font_License_1.1.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/ttf-genjyuu-gothic.install b/ttf-genjyuu-gothic.install
new file mode 100644
index 000000000000..5dee5923b4fb
--- /dev/null
+++ b/ttf-genjyuu-gothic.install
@@ -0,0 +1,13 @@
+post_install() {
+ fc-cache >/dev/null -f
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}