summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2018-07-02 16:55:48 +0300
committerAdrian Perez de Castro2018-07-02 16:55:48 +0300
commite3adebaa21a065a4169a4907186b50be7d2be3f9 (patch)
treedbafc52bff3022807c6c82805839950a285b8c24
downloadaur-e3adebaa21a065a4169a4907186b50be7d2be3f9.tar.gz
Initial import
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD19
3 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..937936ea21a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = ttf-gidole
+ pkgdesc = Open Source Modern DIN typeface
+ pkgver = 0.7
+ pkgrel = 1
+ url = http://gidole.github.io/
+ arch = any
+ license = custom:OFL
+ source = https://github.com/larsenwork/Gidole/raw/v.0.7/Resources/Gidole.zip
+ sha512sums = 6465679c42a9b54fd707f4d17f15e6c3e8ec9d0baa5cb50d2d6d398834b822ca0530894af3e4e3405547073f9063197452b570ad90c37c9abc9bb87707bd53b6
+
+pkgname = ttf-gidole
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..29999f855fc0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg/
+/src/
+/*.tar
+/*.tar.*
+/*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5a38b8398a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
+pkgname=ttf-gidole
+pkgdesc='Open Source Modern DIN typeface'
+pkgver=0.7
+pkgrel=1
+url='http://gidole.github.io/'
+license=(custom:OFL)
+arch=(any)
+source=("https://github.com/larsenwork/Gidole/raw/v.${pkgver}/Resources/Gidole.zip")
+sha512sums=('6465679c42a9b54fd707f4d17f15e6c3e8ec9d0baa5cb50d2d6d398834b822ca0530894af3e4e3405547073f9063197452b570ad90c37c9abc9bb87707bd53b6')
+
+package ()
+{
+ install -Dm644 Releases/Gidole-Regular.ttf \
+ "${pkgdir}/usr/share/fonts/${pkgname}/Gidole-Regular.ttf"
+ install -Dm644 Releases/License.txt \
+ "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}
+