summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDevin Christensen2015-12-04 18:30:46 -0700
committerDevin Christensen2015-12-04 18:30:46 -0700
commit9fe32779cf163a1a603521f63397edae176f5ad9 (patch)
tree882a262669ebd180640665bb807062e98d44c0e6
downloadaur-9fe32779cf163a1a603521f63397edae176f5ad9.tar.gz
Add ttf-hack-powerline-git to AUR
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
-rw-r--r--ttf-hack-powerline-git.install15
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dbf0a3c5e52f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ttf-hack-powerline-git
+ pkgdesc = Hack for Powerline
+ pkgver = r98.6ac4c01
+ pkgrel = 1
+ url = https://github.com/powerline/fonts
+ install = ttf-hack-powerline-git.install
+ arch = any
+ license = custom:SIL OFL, v1.1 + Bitstream License
+ makedepends = git
+ depends = fontconfig
+ depends = xorg-font-utils
+ conflicts = powerline-fonts
+ conflicts = powerline-fonts-git
+ source = git://github.com/powerline/fonts.git
+ md5sums = SKIP
+
+pkgname = ttf-hack-powerline-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a84d07546c6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Devin Christensen <quixoten at gmail dot com>
+pkgname=ttf-hack-powerline-git
+pkgver=r98.6ac4c01
+pkgrel=1
+pkgdesc="Hack for Powerline"
+arch=('any')
+url=('https://github.com/powerline/fonts')
+license=('custom:SIL OFL, v1.1 + Bitstream License')
+depends=(fontconfig xorg-font-utils )
+makedepends=('git')
+conflicts=(powerline-fonts powerline-fonts-git)
+install=$pkgname.install
+source=('git://github.com/powerline/fonts.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd fonts
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $srcdir/fonts/Hack
+ find . -iname '*.ttf' -execdir install -Dm644 {} $pkgdir/usr/share/fonts/TTF/{} \;
+ install -Dm644 LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/ttf-hack-powerline-git.install b/ttf-hack-powerline-git.install
new file mode 100644
index 000000000000..83322116247a
--- /dev/null
+++ b/ttf-hack-powerline-git.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ mkfontscale /usr/share/fonts/TTF > /dev/null 2>&1
+ mkfontdir /usr/share/fonts/TTF > /dev/null 2>&1
+ fc-cache -s >/dev/null
+ echo "done"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}