summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoru0a2662021-05-01 19:48:05 +0900
committeru0a2662021-05-01 19:48:05 +0900
commit5a6aac244af56ed4ed5c31307a4ea0997f9e581b (patch)
tree0e8613e2e794fa1f68d671cb97b62fd177fb9aeb
downloadaur-5a6aac244af56ed4ed5c31307a4ea0997f9e581b.tar.gz
Update
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5865410828cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ttf-hackgen-nerd
+ pkgdesc = HackGen is a composite font of Hack and GenJyuu-Gothic.
+ pkgver = 2.3.2
+ pkgrel = 1
+ url = https://github.com/yuru7/HackGen
+ arch = any
+ license = custom
+ source = https://github.com/yuru7/HackGen/releases/download/v2.3.2/HackGenNerd_v2.3.2.zip
+ source = https://raw.githubusercontent.com/yuru7/HackGen/v2.3.2/LICENSE.txt
+ sha256sums = f685accfa35ecc3e1a6927270e16d800b3b1c4527871cb3efca1e84651ff16e9
+ sha256sums = 8ac2fc3472cd8c8c988bbd047a9739f528f614a3e61ff0925e26d2e76e53301d
+
+pkgname = ttf-hackgen-nerd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7b2eb96e3e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=ttf-hackgen-nerd
+pkgver=2.3.2
+pkgrel=1
+pkgdesc="HackGen is a composite font of Hack and GenJyuu-Gothic."
+arch=("any")
+url="https://github.com/yuru7/HackGen"
+license=("custom")
+source=("${url}/releases/download/v${pkgver}/HackGenNerd_v${pkgver}.zip"
+ "https://raw.githubusercontent.com/yuru7/HackGen/v${pkgver}/LICENSE.txt")
+sha256sums=('f685accfa35ecc3e1a6927270e16d800b3b1c4527871cb3efca1e84651ff16e9'
+ '8ac2fc3472cd8c8c988bbd047a9739f528f614a3e61ff0925e26d2e76e53301d')
+
+package() {
+ install -d ${pkgdir}/usr/share/fonts/TTF
+ install -m644 HackGenNerd_v${pkgver}/*.ttf ${pkgdir}/usr/share/fonts/TTF/
+
+ cd ${srcdir}
+
+ install -D -m644 LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt
+}
+