summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Rice2015-06-24 04:22:06 +1000
committerTimothy Rice2015-06-24 04:22:06 +1000
commit6b2a815ca219a225cbeb9bd6ac8539e3e3c6eef8 (patch)
tree9088152d0acba507e03283eee6d329d19c69cb68
downloadaur-6b2a815ca219a225cbeb9bd6ac8539e3e3c6eef8.tar.gz
Initial import.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD24
-rw-r--r--ttf.install15
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65135db7688b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-humor-sans
+ pkgdesc = A sanserif typeface in the style of xkcd.
+ pkgver = 1.0
+ pkgrel = 2
+ url = http://xkcdsucks.blogspot.com.au/2009/03/xkcdsucks-is-proud-to-present-humor.html
+ install = ttf.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://antiyawn.com/uploads/Humor-Sans-1.0.ttf
+ source = http://antiyawn.com/uploads/Humor-SansOFL-1.0.txt
+ md5sums = acdc29df52454684fe8f3184f6477290
+ md5sums = 5e34faa99b0587e34636534175810dc3
+
+pkgname = ttf-humor-sans
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..243e852793a2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+Humor-Sans*.ttf
+Humor-SansOFL*.txt
+ttf-humor-sans-*.tar.*
+*.swp
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e7775793efb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: "devzero" (Tim Rice) <t dot rice at ms dot unimelb dot edu dot au>
+pkgname=ttf-humor-sans
+_realname=Humor-Sans
+pkgver=1.0
+_licence_name=${_realname}OFL-$pkgver.txt
+pkgrel=2
+pkgdesc="A sanserif typeface in the style of xkcd."
+arch=(any)
+url="http://xkcdsucks.blogspot.com.au/2009/03/xkcdsucks-is-proud-to-present-humor.html"
+license=('custom')
+depends=('fontconfig' 'xorg-font-utils')
+install=ttf.install
+source=(http://antiyawn.com/uploads/$_realname-$pkgver.ttf http://antiyawn.com/uploads/$_licence_name)
+
+build() { :
+}
+package() {
+ cd "$srcdir"
+ install -dm755 "$pkgdir/usr/share/fonts/TTF"
+ install -Dm644 *.ttf "$pkgdir/usr/share/fonts/TTF"
+ install -D -m644 "$_licence_name" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+md5sums=('acdc29df52454684fe8f3184f6477290'
+ '5e34faa99b0587e34636534175810dc3')
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..33b7d65490db
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "==> Rebuilding font cache... "
+ fc-cache -f &> /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}