summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorN. Izumi2015-11-18 05:28:21 +0800
committerN. Izumi2015-11-18 05:30:56 +0800
commit3e5e3e826c6dc9aa7dc53498684cb95762d1c506 (patch)
tree72e8079cbcba381167eb91fff17864e4aba574ad
downloadaur-3e5e3e826c6dc9aa7dc53498684cb95762d1c506.tar.gz
initial
-rw-r--r--.SRCINFO16
-rw-r--r--INSTALL15
-rw-r--r--PKGBUILD22
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d70aab7a8d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-i.bming
+ pkgdesc = An old-style CJK serif font.
+ pkgver = 3.5
+ pkgrel = 1
+ url = http://founder.acgvlyric.org/iu/doku.php/造字:開源字型_i.明體
+ install = INSTALL
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ options = !strip
+ source = http://input.foruto.com/ccc/1.font/font/I.BMing3.5.zip
+ sha512sums = 7a3aa034d67074bb2a9b8da7cbcef39f7de53cb71de4ef6a37499b67f498f669e750d4a1a616a903754bce9e95df2aa325e673dc26af7632524fd088b0c1858b
+
+pkgname = ttf-i.bming
+
diff --git a/INSTALL b/INSTALL
new file mode 100644
index 000000000000..a5bbeb8775fe
--- /dev/null
+++ b/INSTALL
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache..."
+ fc-cache -fs > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3711f80d9bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: izmntuk
+pkgname=ttf-i.bming
+pkgdesc='An old-style CJK serif font.'
+pkgver=3.5
+pkgrel=1
+url='http://founder.acgvlyric.org/iu/doku.php/造字:開源字型_i.明體'
+arch=('any')
+license=('custom')
+depends=('fontconfig' 'xorg-font-utils')
+install='INSTALL'
+options=('!strip')
+source=("http://input.foruto.com/ccc/1.font/font/I.BMing3.5.zip")
+
+package() {
+ cd "${srcdir}"
+ install -d "${pkgdir}/usr/share/fonts/TTF" "${pkgdir}/usr/share/"{licenses,doc}"/${pkgname}"
+ install -m644 I.BMing_{history,readme}.txt "${pkgdir}/usr/share/doc/${pkgname}"
+ install -m644 IPA_Font_License_Agreement_v1.0.txt "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -pm644 "I.BMing-3.500.ttf" "${pkgdir}/usr/share/fonts/TTF"
+}
+
+sha512sums=('7a3aa034d67074bb2a9b8da7cbcef39f7de53cb71de4ef6a37499b67f498f669e750d4a1a616a903754bce9e95df2aa325e673dc26af7632524fd088b0c1858b')