summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcos Heredia2015-06-09 11:25:08 -0300
committerMarcos Heredia2015-06-09 11:25:08 -0300
commitf965748331c7b2bff6e326e9631d3a6d0704dc6f (patch)
tree2c6caba1313eef94f4d3c1e5c5ade69681e9c8fa
downloadaur-f965748331c7b2bff6e326e9631d3a6d0704dc6f.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--updatefont.install16
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73e9ad62ca30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-impallari-cabin-font
+ pkgdesc = A humanist sans inspired by Edward Johnston's and Eric Gill's typefaces, from Pablo Impallari
+ pkgver = 1.5
+ pkgrel = 1
+ url = http://www.impallari.com/cabin/
+ install = updatefont.install
+ arch = any
+ groups = impallari-fonts
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.impallari.com/media/releases/cabin-font-v1.5.zip
+ md5sums = ae4b0e4e0298ac88589b8e57629a6a08
+
+pkgname = ttf-impallari-cabin-font
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5dc7a6e478f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Marcos Heredia <chelqo@gmail.com>
+
+_font="cabin-font"
+_group="impallari"
+pkgname=ttf-${_group}-${_font}
+pkgver=1.5
+pkgrel=1
+pkgdesc="A humanist sans inspired by Edward Johnston's and Eric Gill's typefaces, from Pablo Impallari"
+arch=(any)
+url="http://www.impallari.com/cabin/"
+license=('custom:OFL')
+groups=("${_group}-fonts")
+depends=('fontconfig' 'xorg-font-utils')
+install=updatefont.install
+source=("http://www.impallari.com/media/releases/${_font}-v${pkgver}.zip")
+md5sums=('ae4b0e4e0298ac88589b8e57629a6a08')
+
+package() {
+ cd ${srcdir}/*
+
+ install -dm755 "${pkgdir}/usr/share/fonts/TTF/${_group}"
+ install -Dpm644 *.ttf "${pkgdir}/usr/share/fonts/TTF/${_group}"
+
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dpm644 OFL.txt "${pkgdir}/usr/share/licenses/${pkgname}/"
+
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -Dpm644 FONTLOG.txt "${pkgdir}/usr/share/doc/${pkgname}/"
+}
diff --git a/updatefont.install b/updatefont.install
new file mode 100644
index 000000000000..7c7762f6887c
--- /dev/null
+++ b/updatefont.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}