summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcos Heredia2015-06-09 11:26:06 -0300
committerMarcos Heredia2015-06-09 11:26:06 -0300
commite9b93e5369bcd8b6205564626b9876805ab21319 (patch)
tree3d87b7ebc5e9b07888a22c939f7a1995713c156d
downloadaur-e9b93e5369bcd8b6205564626b9876805ab21319.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--updatefont.install15
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..944861ee6403
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-impallari-dancing-script
+ pkgdesc = Lively casual script where the letters bounce and change size slightly, from Pablo Impallari
+ pkgver = 1.2
+ pkgrel = 1
+ url = http://www.impallari.com/dancing/
+ install = updatefont.install
+ arch = any
+ groups = impallari-fonts
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.impallari.com/media/releases/dancing-script-v1.2.zip
+ md5sums = 2dff08125b75464d697b83c1d931b136
+
+pkgname = ttf-impallari-dancing-script
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be045b5bee47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Marcos Heredia <chelqo@gmail.com>
+
+_font="dancing-script"
+_group="impallari"
+pkgname=ttf-${_group}-${_font}
+pkgver=1.2
+pkgrel=1
+pkgdesc="Lively casual script where the letters bounce and change size slightly, from Pablo Impallari"
+arch=(any)
+url="http://www.impallari.com/dancing/"
+license=('custom:OFL')
+groups=("${_group}-fonts")
+depends=('fontconfig' 'xorg-font-utils')
+install=updatefont.install
+source=("http://www.impallari.com/media/releases/${_font}-v${pkgver}.zip")
+md5sums=('2dff08125b75464d697b83c1d931b136')
+
+package() {
+ cd ${srcdir}/*
+
+ install -dm755 "${pkgdir}/usr/share/fonts/TTF/${_group}"
+ install -Dpm644 *.ttf "${pkgdir}/usr/share/fonts/TTF/${_group}"
+
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dpm644 OFL.txt "${pkgdir}/usr/share/licenses/${pkgname}/"
+
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -Dpm644 FONTLOG.txt "${pkgdir}/usr/share/doc/${pkgname}/"
+}
diff --git a/updatefont.install b/updatefont.install
new file mode 100644
index 000000000000..43e14fbd0cff
--- /dev/null
+++ b/updatefont.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}