summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcos Heredia2015-06-09 11:26:48 -0300
committerMarcos Heredia2015-06-09 11:26:48 -0300
commitbc46b9bb4443c540d6e514ed09ec7b6d86e99744 (patch)
tree46135ff516f5eb302035ef214f66d43af046bd62
downloadaur-bc46b9bb4443c540d6e514ed09ec7b6d86e99744.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
-rw-r--r--updatefont.install15
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c37c28561e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-impallari-encode-sans
+ pkgdesc = Encode Sans Font: Obsessively optimized for the web, from Pablo Impallari
+ pkgver = 1.000
+ pkgrel = 1
+ url = http://www.impallari.com/projects/overview/encode
+ install = updatefont.install
+ arch = any
+ groups = impallari-fonts
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.impallari.com/media/uploads/prosources/update-106-source.zip
+ md5sums = cec291f414c9b4020395b095c04594aa
+
+pkgname = ttf-impallari-encode-sans
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..330e91398aae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Marcos Heredia <chelqo@gmail.com>
+
+_font="encode-sans"
+_group="impallari"
+_update="106"
+pkgname=ttf-${_group}-${_font}
+pkgver=1.000
+pkgrel=1
+pkgdesc="Encode Sans Font: Obsessively optimized for the web, from Pablo Impallari"
+arch=(any)
+url="http://www.impallari.com/projects/overview/encode"
+screenshot="http://www.impallari.com/media/uploads/profotos/135-foto01-original.jpg"
+license=('custom:OFL')
+groups=("${_group}-fonts")
+depends=('fontconfig' 'xorg-font-utils')
+install=updatefont.install
+source=("http://www.impallari.com/media/uploads/prosources/update-${_update}-source.zip")
+md5sums=('cec291f414c9b4020395b095c04594aa')
+
+package() {
+ cd ${srcdir}/E*
+
+ install -dm755 "${pkgdir}/usr/share/fonts/TTF/${_group}"
+ install -Dpm644 *.ttf "${pkgdir}/usr/share/fonts/TTF/${_group}"
+
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dpm644 OFL.txt "${pkgdir}/usr/share/licenses/${pkgname}/"
+
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -Dpm644 FONTLOG.txt "${pkgdir}/usr/share/doc/${pkgname}/"
+}
diff --git a/updatefont.install b/updatefont.install
new file mode 100644
index 000000000000..43e14fbd0cff
--- /dev/null
+++ b/updatefont.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}