summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcos Heredia2015-06-09 11:27:30 -0300
committerMarcos Heredia2015-06-09 11:27:30 -0300
commit3d213fb78210a20994e2465b507cfc439863ad86 (patch)
treeed66d9695d14e612d0f1b115cc5d600953b5da7e
downloadaur-3d213fb78210a20994e2465b507cfc439863ad86.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--updatefont.install16
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3fe9e93c617
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-impallari-kaushan-script
+ pkgdesc = Feels like writing quickly with an inked brush, from Pablo Impallari
+ pkgver = 1.02
+ pkgrel = 1
+ url = http://www.impallari.com/kaushan/
+ install = updatefont.install
+ arch = any
+ groups = impallari-fonts
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.impallari.com/media/releases/kaushan-script-v.1.02.zip
+ md5sums = 56c4d12b0afa2064249f258f2d8f6171
+
+pkgname = ttf-impallari-kaushan-script
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..075c305c8ef0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Marcos Heredia <chelqo@gmail.com>
+
+_font="kaushan-script"
+_group="impallari"
+pkgname=ttf-${_group}-${_font}
+pkgver=1.02
+pkgrel=1
+pkgdesc="Feels like writing quickly with an inked brush, from Pablo Impallari"
+arch=(any)
+url="http://www.impallari.com/kaushan/"
+license=('custom:OFL')
+groups=("${_group}-fonts")
+depends=('fontconfig' 'xorg-font-utils')
+install=updatefont.install
+source=("http://www.impallari.com/media/releases/${_font}-v.${pkgver}.zip")
+md5sums=('56c4d12b0afa2064249f258f2d8f6171')
+
+package() {
+ cd ${srcdir}/*
+
+ install -dm755 "${pkgdir}/usr/share/fonts/TTF/${_group}"
+ install -Dpm644 *.ttf "${pkgdir}/usr/share/fonts/TTF/${_group}"
+
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dpm644 OFL.txt "${pkgdir}/usr/share/licenses/${pkgname}/"
+
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -Dpm644 FONTLOG.txt "${pkgdir}/usr/share/doc/${pkgname}/"
+}
diff --git a/updatefont.install b/updatefont.install
new file mode 100644
index 000000000000..7c7762f6887c
--- /dev/null
+++ b/updatefont.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}