summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcos Heredia2015-06-09 11:27:44 -0300
committerMarcos Heredia2015-06-09 11:27:44 -0300
commitaf3151c5293fc335a97045cd72f58b89f09e0d26 (patch)
tree1fbd3a66ea53669413f4c0d5a8f82bd4cf12cfea
downloadaur-af3151c5293fc335a97045cd72f58b89f09e0d26.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
-rw-r--r--updatefont.install15
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9fd6ba073d60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttf-impallari-libre-baskerville
+ pkgdesc = Libre Baskerville is webfont optimized for web body text, from Pablo Impallari
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.impallari.com/projects/overview/libre-baskerville/
+ install = updatefont.install
+ arch = any
+ groups = impallari-fonts
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.impallari.com/media/uploads/prosources/update-86-source.zip
+ md5sums = b9a7656f62e06fdee0086c39a446b28b
+
+pkgname = ttf-impallari-libre-baskerville
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93e21768e420
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Marcos Heredia <chelqo@gmail.com>
+
+_font="libre-baskerville"
+_group="impallari"
+pkgname=ttf-${_group}-${_font}
+pkgver=1.0
+pkgrel=1
+pkgdesc="Libre Baskerville is webfont optimized for web body text, from Pablo Impallari"
+arch=(any)
+url="http://www.impallari.com/projects/overview/${_font}/"
+screenshot="http://www.impallari.com/media/uploads/profotos/132-foto01-original.jpg"
+license=('custom:OFL')
+groups=("${_group}-fonts")
+depends=('fontconfig' 'xorg-font-utils')
+install=updatefont.install
+#source=("http://www.impallari.com/media/releases/${_font}-v${pkgver}.zip")
+source=("http://www.impallari.com/media/uploads/prosources/update-86-source.zip")
+md5sums=('b9a7656f62e06fdee0086c39a446b28b')
+
+package() {
+ cd ${srcdir}/L*
+
+ install -dm755 "${pkgdir}/usr/share/fonts/TTF/${_group}"
+ install -Dpm644 *.ttf "${pkgdir}/usr/share/fonts/TTF/${_group}"
+
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dpm644 OFL.txt "${pkgdir}/usr/share/licenses/${pkgname}/"
+
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -Dpm644 FONTLOG.txt "${pkgdir}/usr/share/doc/${pkgname}/"
+}
diff --git a/updatefont.install b/updatefont.install
new file mode 100644
index 000000000000..43e14fbd0cff
--- /dev/null
+++ b/updatefont.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}